Article ID: 111711, created on Mar 26, 2013, last review on Aug 12, 2014

  • Applies to:
  • Plesk 11.0 for Linux
  • Plesk 10.x for Linux

解决方案

要在 Parallels Plesk Panel   服务器上启用 PHP 5.3 支持可使用以下方式:

1 使用以下命令行通过 Autoinstaller 工具在服务器上安装 PHP 5.3 :
/usr/local/psa/admin/sbin/autoinstaller --select-release-current --install-component php53

2 从 Parallels Plesk Panel web 界面安装 PHP 5.3:
工具 & 设置 > Panel 更新 > 添加组件 > 选择 PHP5.3 支持 并继续。


3 通过 EZ 模板安装 Parallels Plesk Panel 10.4 和 PHP 5.3。应用程序模板 "pp10-php53" 计划在安装 Plesk Panel 的过程中使用。
这表示您需要以下面的方式使用该模板:
   
# vzctl create CTID --ostemplate centos-5-x86_64 --hostname plesk10.centos5 --ipadd NN.MM.KK.LL
# vzctl set CTID --save --applyconfig slm.2048MB
# vzctl start CTID
# vzpkg install CTID pp10 pp10-php53


4 按照以下文章中的说明通过 Parallels Plesk Panel 更新 container 上的 PHP 5.x EZ 模板到 5.3 版本:

113432 如何更新 container 上的 PHP 5.x EZ 模板到 5.3 版本

其它信息

要获取更多有关组件升级的信息,请参阅 Parallels Plesk Panel 10:安装和升级指南.

 

dd0611b6086474193d9bf78e2b293040 a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 56797cefb1efc9130f7c48a7d1db0f0c aea4cd7bfd353ad7a1341a257ad4724a 0a53c5a9ca65a74d37ef5c5eaeb55d7f

Email subscription for changes to this article