Article ID: 113179, created on Jun 11, 2012, last review on May 11, 2014

  • Applies to:
  • Plesk 11.0 for Windows
  • Plesk 10.4 for Windows

解决方案

您可通过自动安装程序设置 Parallels Plesk Panel 10.4.4 中的 PHP 5.3 支持: 工具 & 设置 > 更新与升级

在自动安装程序中选择"添加组件",然后在"Plesk 主机功能"组中选择"PHP5.3 脚本引擎。"




您还可通过以下命令设置 PHP 5.3 支持:
"%plesk_bin%\ai.exe" --select-release-id PANEL_10_4_4_WIN --install-component php53
您可在域名的主机设置中为一个域名设置启用 PHP 5.3 支持:



您可使用以下命令创建带有 PHP 5.3 支持的域名:
"%plesk_dir%\bin\domain.exe --create mydomain.name -hosting true -hst_type phys -clogin admin -login ftpuser1 -passwd s$kr3t -ip 10.52.76.75 -php true -php_version 5.3
您可使用以下命令为一个现存域名启用 PHP 5.3 支持:
"%plesk_dir%\bin\domain.exe --update mydomain.name -php true -php_version 5.3
而且您还可在服务方案中为域名定义 PHP 5.3 支持:



可使用以下命令创建带有 PHP 5.3 支持的服务方案。
service_plan.exe --create newplan -php true -php_version 5.3

对于现存服务方案,可使用以下命令启用 PHP 5.3 支持:
service_plan.exe --update "Default Domain" -php true -php_version 5.3
所有以上操作可与 API-RPC 请求一起执行。 例如:
<packet version="1.6.3.0">
<site>
<set>
<filter>
<name>mysite.name</name>
</filter>
<values>
<hosting>
<vrt_hst>
<property>
<name>php_version</name>
<value>5.3</value>
</property>
</vrt_hst>
</hosting>
</values>
</set>
</site>
</packet>

其他信息

- date.timezone 参数在 %plesk_dir%\Additional\PleskPHP53\php.ini 中设为 UTC。
- 在 PHP 5.3 版本中禁用作为 ISAPI 进行 PHP 操作。 在 Plesk 中 PHP 5.3 在 CGI 或 FastCGI 模式中运行。
jmn- 如果 Plesk 安装有 Microsoft SQL Server 2005,对 PHP 扩展 sqlsrvsqlpdo 进行正确操作,还需在 Plesk 服务器上安装 MS SQL Server 2008 Native Client。

56797cefb1efc9130f7c48a7d1db0f0c ff5a00b8ead2e480367b019417a04207 a914db3fdc7a53ddcfd1b2db8f5a1b9c 85a92ca67f2200d36506862eaa6ed6b8 c796c01d6951fa24ed54c7f1111667c6 514af229ae32522202a910a2649c80fb bd7fc88cf1b01f097749ae6f87272128

Email subscription for changes to this article