Article ID: 114373, created on Jul 23, 2012, last review on Aug 12, 2014

  • Applies to:
  • Plesk 10.3 for Linux/Unix
  • Plesk 10.2 for Linux/Unix
  • Plesk 10.1 for Linux/Unix
  • Plesk 10.0.x for Linux/Unix
  • Plesk 9.5 for Linux/Unix
  • Plesk 9.3 for Linux/Unix
  • Plesk 9.2 for Linux/Unix
  • Plesk 9.0 for Linux/Unix

解决方案

Plesk 服务团队已经为 Atmail 升级到 1.05  版本的脚步准备了所有的安全更新。该脚本可用于安装有 Plesk for Linux 9.0.0 - 10.3.1 版本的服务器。
 
注意:如果您升级 Plesk 到低于 10.4.4 的版本,会再次安装 Atmail 旧版本。因此我们建议您升级到最新的可用 Plesk 版本或如以下说明再次执行 Atmail 升级。
 
升级步骤:

1. 创建当前 Atmail 版本与数据库的备份:
# HTTPD_VHOSTS_D=`cat /etc/psa/psa.conf | grep HTTPD_VHOSTS_D| awk {'print $2'}`
# DUMP_D=`cat /etc/psa/psa.conf | grep DUMP_D| head -1 | awk {'print $2'}`
# HTTPD_INCLUDE_D=`cat /etc/psa/psa.conf | grep HTTPD_INCLUDE_D| awk {'print $2'}`
# cp -r $HTTPD_VHOSTS_D/../atmail $DUMP_D
# cp $HTTPD_INCLUDE_D/zzz_atmail_vhost.conf $DUMP_D
# cp -r /etc/psa/webmail $DUMP_D || cp -r /etc/psa-webmail $DUMP_D
# mysqldump -uadmin -p`cat /etc/psa/.psa.shadow` atmail > $DUMP_D/atmail/atmail.db


2. 上传附加的存档与脚本到 /usr/local/psa/var directory:
# cd /usr/local/psa/var
# wget http://kb.sp.parallels.com/Attachments/20959/Attachments/atmail_105.tar.gz
# wget http://kb.sp.parallels.com/Attachments/20959/Attachments/atmail_install.sh

 
3. 运行脚本:
# chmod +x atmail_install.sh
# ./atmail_install.sh
Trying to unpack atmail archive... done
Trying to replace atmail virtual host directory... done
Trying to configure atmail... done

Attachments

60d3e722783ac7177a2b4b4c13af4062 56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 6ef0db7f1685482449634a455d77d3f4 165ec78c924fabffe1d80dc3eabc98c6 f4ce8084cb23619ef5fe9428ecc388ea dd0611b6086474193d9bf78e2b293040 d3c493291d6d9f66837ac7495dfea9ca b21de1858ad3ec50d5613195a77434ab 4f57df935e9acf8d18830757d2346419 11a46d8a188d618564f4f0cead9a50f3 def31538ba607bde27398f48ab5956be

Email subscription for changes to this article