Article ID: 114982, created on Apr 10, 2013, last review on May 11, 2014

  • Applies to:
  • Plesk Automation 11.5
  • Plesk 12.0 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 10.4 for Linux/Unix

问题

我收到 maillog 中的以下错误信息:

Oct  9 13:20:04 vps-1011114-876 postfix/smtpd[31266]: connect from unknown[unknown]
Oct  9 13:20:04 vps-1011114-876 /usr/lib64/plesk-9.0/psa-pc-remote[1489]: Unable to interpret remote host address
Oct  9 13:20:04 vps-1011114-876 postfix/smtpd[31266]: NOQUEUE: milter-reject: CONNECT from unknown[unknown]: 451 4.7.1 Service
unavailable - try again later; proto=SMTP
Oct  9 13:20:04 vps-1011114-876 postfix/smtpd[31266]: lost connection after CONNECT from unknown[unknown]
Oct  9 13:20:04 vps-1011114-876 postfix/smtpd[31266]: disconnect from unknown[unknown]


我需要进行任何相关的操作吗?

原因

会因以下情况而出现以上信息:

1) 基于 TCP 创建的连接;
2) Postfix 收到有关此信息的信号并开始处理请求;
3) 有很多操作必须在 Postfix 获取网络连接详情之前完成,而 Postfix 尝试获取插座详情时连接处于关闭状态;
4) 因为系统已经关闭了连接,当数据已被收集时,会确定并记录"未知" IP 地址。

如果存在以下事实会出现此类情况:

1) 远程(或中间)主机在连接建立(端口探测或端口扫描)后立即关闭了连接

2) 本地系统处于高负载状态或在网络堆栈中处于资源短缺状态。

第一种情况通常很难进行故障排除纯属系统管理员任务。

第二种情况需要好好调查因为这将会影响服务器上所有的网络服务。

不管怎样,如果无法创建 SMTP 会话,该信息都会被延迟,而计划再次尝试交付此信息。 最终都会交付此信息。

解决方案

查看系统资源是否可用且确定该服务器是否超负载。

注意: 这纯属系统管理员任务而不能提交为技术支持请求。

56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 0a53c5a9ca65a74d37ef5c5eaeb55d7f aea4cd7bfd353ad7a1341a257ad4724a 01bc4c8cf5b7f01f815a7ada004154a2 2a5151f57629129e26ff206d171fbb5f e335d9adf7edffca6a8af8039031a4c7 e8756e9388aeca36710ac39e739b2b37 dd0611b6086474193d9bf78e2b293040 33a70544d00d562bbc5b17762c4ed2b3 caea8340e2d186a540518d08602aa065 e0aff7830fa22f92062ee4db78133079

Email subscription for changes to this article