Article ID: 1339, created on May 10, 2013, last review on Apr 26, 2014

  • Applies to:
  • Plesk 8.x for Windows
  • Plesk 7.x for Windows

问题

当尝试登录 Plesk Panel 时出现以下错误:

The file filename.php is part of Plesk distribution.It cannot be run outside of Plesk environment.

原因

一个 * .php 文件无法被 Plesk 引擎加密。可能会因为以下原因:

1. 安装的 Plesk 密钥无效。意思是说您已安装了适用于 Linux 的而不是用于 Windows 的 Plesk 密钥,反之亦然。

2. 该 Plesk php 环境已损坏。

解决方案

要解决第一个问题您需要完成以下步骤:

1. 关闭浏览器,或确定您的浏览器不显示缓存 web 页面。

2. 停止 Plesk 控制面板服务。

3. 移除 %plesk_dir%PrivateTemp 目录内的所有文件。重设当前的 Plesk 为默认的 PLSK.00000000.0000.您可以通过使用附加到该文章的 defpkey.reg 来实现此操作。

4. 启动 Plesk 控制面板服务。

5. 直接从 Plesk Panel 重新上传有效的 Plesk 密钥。您可以上传 PLSK.XXXXXXXX.XXXX.exe 密钥。

要解决第二个问题您需要完成以下步骤:

1. 切换 Plesk web 服务器为其它服务器。

如果 IIS 用于 Plesk web 服务器请切换至 Apache:

%plesk_bin%\reconfigurator.exe --switch-plesk-web-server --new-provider=apache

如果 Apache 用于 Plesk web 服务器请切换至 IIS:

%plesk_bin%\reconfigurator.exe --switch-plesk-web-server --new-provider=iis


一完成这些步骤就查看 Plesk 是否运行正常。如果出现同样的错误,那么 Plesk PHP 文件已被损坏。这样的情况下,您需要在 添加或移除程序 中运行 Plesk 修复。

Attachments

85a92ca67f2200d36506862eaa6ed6b8 a914db3fdc7a53ddcfd1b2db8f5a1b9c c45acecf540ecd42a4bbfb242ce02b1d c0c38d2367acfa8909699e0b34b01dea 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article