Article ID: 112251, created on Feb 26, 2013, last review on May 11, 2014

  • Applies to:
  • Plesk 10.3 for Linux/Unix
  • Plesk 10.2 for Linux/Unix

Kennzeichen

 Nach dem Upgrade auf eine neuere Version von Parallels Plesk Panel ist es nicht mehr möglich, den Control-Panel-Dienst zu starten. Die nachfolgende Fehlermeldung wird angezeigt:
# service psa start
Starting psa...                                                       failed
Starting xinetd service...                                            done
Starting named service...                                             done
Starting mysqld service...                                            done
Starting postgresql service...                                        done
Starting psa-spamassassin service...                                  done
Plesk: Starting Mail Server...                                        done
Starting mail handlers tmpfs storage
Starting psa...                                                       failed
Starting drwebd service...                                            failed

#/etc/init.d/sw-cp-server start
Starting SWsoft control panels server... Duplicate config variable in conditional 0 global: var.sso_username
2011-04-14 05:48:16: (configfile.c.838) source: /usr/share/sw-cp-server/applications-conf.sh line: 72 pos: 11 parser failed somehow near here: (EOL)
2011-04-14 05:48:16: (configfile.c.838) source: /etc/sw-cp-server/config line: 13 pos: 1 parser failed somehow near here: (EOL)
 

Ursache

Es wurden zwei Versionen des sw-sso-Pakets während des Upgrades installiert. Diese Pakete enthalten in Konflikt stehende Startskripte.

Lösung

Schritt 1: Finden Sie heraus, welche Pakete in Konflikt stehen:
#ls /etc/sw-cp-server/applications.d/*sso*
/etc/sw-cp-server/applications.d/00-sso-cpserver.conf
/etc/sw-cp-server/applications.d/sso-cpserver.conf
# rpm -qf /etc/sw-cp-server/applications.d/00-sso-cpserver.conf
sw-sso-2.7-11062309
# rpm -qf /etc/sw-cp-server/applications.d/sso-cpserver.conf{
sw-sso-2.2-r3488


Schritt 2: Benennen Sie die Datei des älteren sw-sso-Pakets um:
#mv /etc/sw-cp-server/applications.d/sso-cpserver.conf /etc/sw-cp-server/applications.d/sso-cpserver.conf.bak


Schritt 3: Entfernen Sie das ältere sw-sso-Paket:
#rpm -e sw-sso-2.2-r3488 --nodeps --justdb


Schritt 4: Starten Sie Parallels Plesk Panel:
# /etc/init.d/psa start
Starting psa...                                                       done
Starting xinetd service...                                            done
Starting named service...                                             done
Starting mysqld service...                                            done
Starting postgresql service...                                        done
Starting psa-spamassassin service...                                  done
Plesk: Starting Mail Server... already started
Starting mail handlers tmpfs storage
Starting psa...                                                       done
Starting drwebd service...                                            done

dd0611b6086474193d9bf78e2b293040 a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 f4ce8084cb23619ef5fe9428ecc388ea d3c493291d6d9f66837ac7495dfea9ca 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF