Article ID: 113604, created on Jun 11, 2012, last review on Aug 12, 2014

  • Applies to:
  • Plesk 12.5 for Windows

Kennzeichen

Die Kennzeichen variieren:
- Updates/Upgrades schlagen fehl
- Services starten nicht
- Services weisen Fehlfunktionen auf
- Fehler im Control Panel
- Migrationen/Backups schlagen fehl

Ursache

Ein Upgrade der Parallels Plesk Panel (PP) Installation ist möglicherweise fehlgeschlagen.

Ausschluss: Dies ist nur eine mögliche Ursache. Es ist jedoch wichtig, die Ursache zu einem frühen Zeitpunkt der Fehlerbehebungsphase herauszufinden, bevor Sie größere Änderungen am Server vornehmen. Andernfalls kann es schwierig werden, die Installation wieder in einen betriebsfähigen Zustand zu versetzen.

Fehlerdiagnose

Hinweis: Falls mehrere Services Fehlfunktionen aufweisen oder nicht starten, sollten Sie überprüfen, ob genug freier Speicherplatz auf allen Festplattenpartitionen vorhanden ist.

Wir müssen sichergehen, dass alle PP-Komponenten von derselben Version sind. Also überprüfen wir sie nacheinander.

Die Installation selbst:
# cat /usr/local/psa/version
10.4.4 CentOS 5 1013111102.18

Hinweis: Für auf Debian basierende Systeme ist dies üblicherweise "/opt/psa/version."

PSA-Datenbank:
# mysql -uadmin -p`cat /etc/psa/.psa.shadow` -D psa -e 'select * from upgrade_history order by upgrade_date desc limit 1'
+---------------------+--------------+------------+
| upgrade_date        | version_info | db_version |
+---------------------+--------------+------------+
| 2012-03-30 12:48:00 |      10.4.4  |     10.4.4 |
+---------------------+--------------+------------+

Hinweis: Sollten Sie keine Ausgabe sehen, bedeutet dies, dass die Datenbank nie ein Upgrade erfahren hat.

Pakete:
# rpm -q psa
psa-10.4.4-cos5.build1013111102.18

Hinweis: Bei auf Debian basierenden Systemen müssen Sie möglicherweise den Befehl “dpkg –l psa” verwenden.

Analyse der Ergebnisse:
Wenn die angezeigten Versionen nach den oben genannten Schritten nicht übereinstimmen, bedeutet das, dass in der Vergangenheit ein Upgrade Ihrer PP-Installation fehlgeschlagen ist. Fahren Sie in diesem Fall beim Abschnitt Lösung dieses Artikels fort.
Wenn alle drei Versionen übereinstimmen und Sie beim Upgrade-Vorgang von einer älteren PP-Version auf Version 10 waren, können Sie weiter mit der Fehlersuche fortfahren, indem Sie das Überprüfungsprogramm Parallels Plesk Panel Post-Upgrade Checker verwenden.

Lösung

Versuchen Sie, die Ursache des fehlgeschlagenen Upgrades in der Protokolldatei des Autoinstallers zu finden:

/tmp/autoinstaller3.log

Suchen Sie anschließend in unserer Wissensdatenbank nach jener gefundenen Fehlermeldung.

Falls Sie keine nützlichen Informationen in den Protokollen finden, können Sie die Fehlerprotokollierung aktivieren. Eine Beschreibung dazu finden Sie hier:

1139 Wie das Fehlerprotokoll für den Autoinstaller aktiviert wird

Wenn die oben genannten Vorgehensweisen nicht weiterhelfen, können Sie gern die verfügbaren Support-Optionen in unserem Support-Portal (im linken Menü) nutzen.

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