Article ID: 113891, created on May 23, 2013, last review on Apr 26, 2014

  • Applies to:
  • Plesk 12.5 for Linux
  • Plesk 11.5 for Linux

Kennzeichen

Wenn ich versuche, einen Kunden mithilfe der Weboberfläche von Parallels Plesk Panel zu entfernen, erhalte ich in etwa solche Fehlermeldungen:

Internal error.

PHP Warning: stream_socket_client() [function.stream-socket-client]: php_network_getaddresses: getaddrinfo failed: Name or service not known
Line: 139
File: /usr/local/psa/admin/plib/pear/Net/Socket.php
Stack Trace:
#0  Smb_Exception_Syntax::handleError(2, stream_socket_client() [function.stream-socket-client]: php_network_getaddresses: getaddrinfo failed: Name or service not known, /usr/local/psa/admin/plib/pear/Net/Socket.php, 139, Array ([addr] => ssl://sone_hostname:8443,[port] => 8443,[persistent] => ,[timeout] => 30,[options] => Array ([ssl] => Array ([local_cert] => /usr/local/psa/var/sso.sp.pem)),[openfunc] => fsockopen,[errno] => 0,[errstr] => ,[context] => Resource id #342,[flags] => 4))
#1  stream_socket_client(ssl://some_hostname:8443, 0, , 30, 4, Resource id #342) called at [/usr/local/psa/admin/plib/pear/Net/Socket.php:139]
#2  Net_Socket->connect(ssl://some_hostname, 8443, , 30, Array ([ssl] => Array ([local_cert] => /usr/local/psa/var/sso.sp.pem))) called at [/usr/local/psa/admin/plib/pear/HTTP/Request.php:707]
#3  HTTP_Request->sendRequest() called at [/usr/local/psa/admin/plib/sso/SP.php:86]
#4  sso_SP::ssoRemoveSpAccountFromIdP(yourpostcardbusiness.com) called at [/usr/local/psa/admin/plib/Domain.php:1096]
#5  Domain->delete() called at [/usr/local/psa/admin/plib/PhDomain.php:209]
#6  PhDomain->reset(1, ) called at [/usr/local/psa/admin/plib/BsDomain.php:602]
#7  BsDomain->reset() called at [/usr/local/psa/admin/plib/BsDomain.php:558]
#8  BsDomain->delete() called at [/usr/local/psa/admin/plib/Webspace.php:835]
#9  Webspace->delete() called at [/usr/local/psa/admin/plib/BsDomain.php:927]

Ursache

Das Problem kann dadurch hervorgerufen werden, dass der SSO-Server nicht erreichbar ist.

Diagnose

Überprüfen Sie, für die Nutzung welches Servers SSO konfiguriert ist:

# mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa

mysql> select * from misc where param like '%sso%';
+---------------------+----------------------------------------------+
| param | val |
+---------------------+----------------------------------------------+
...
| sso_relay | https://EXAMPLE_HOSTNAME:8443 |
| sso_server | https://EXAMPLE_HOSTNAME:8443 |
| sso_server_user_url | https://EXAMPLE_HOSTNAME:8443 |
+---------------------+----------------------------------------------+
9 rows in set (0.00 sec)

Überprüfen Sie, ob der Server erreichbar ist. Wenn Sie die nachfolgende Ausgabe auch auf Ihrem Bildschirm sehen, sollten Sie unserem Lösungsvorschlag nachkommen.

# ping EXAMPLE_HOSTNAME
ping: unknown host EXAMPLE_HOSTNAME

Hinweis: EXAMPLE_HOSTNAME ist mit dem tatsächlichen Hostnamen aus der Datenbank zu ersetzen.

Lösung

Allgemein gefasst, müssen Sie dafür sorgen, dass der obige Hostname erreichbar ist.

Dies können Sie z. B. erreichen, indem Sie ihn zu der auf dem Server befindlichen Datei "/etc/hosts" hinzufügen:

# cat /etc/hosts
...
EXAMPLE_IP EXAMPLE_HOSTNAME
#

Prüfen Sie, ob es funktioniert hat. Falls dem so ist, wird folgende Ausgabe angezeigt:
# ping EXAMPLE_HOSTNAME
PING EXAMPLE_HOSTNAME (EXAMPLE_IP) 56(84) bytes of data.
64 bytes from EXAMPLE_HOSTNAME (EXAMPLE_IP): icmp_seq=1 ttl=64 time=0.025 ms
...

56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 742559b1631652fadd74764ae8be475e e335d9adf7edffca6a8af8039031a4c7 01bc4c8cf5b7f01f815a7ada004154a2 0a53c5a9ca65a74d37ef5c5eaeb55d7f

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