Article ID: 114245, created on Nov 15, 2012, last review on May 11, 2014

  • Applies to:
  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux

Kennzeichen

Manchmal startet NGINX nach der Änderung einer IP nicht. Sie können folgende Fehlermeldung sehen:
# /etc/init.d/nginx restart
nginx: [emerg] bind() to 10.62.19.50:80 failed (99: Cannot assign requested address)
nginx: configuration file /etc/nginx/nginx.conf test failed

Ursache

Das Problem wird dadurch verursacht, dass die NGINX Konfiguration nach einer IP-Änderung nicht automatisch für die neue IP neu generiert wird.

Lösung

Sie können das Problem mit folgendem Befehl beheben:
# /usr/local/psa/bin/reconfigurator --autoconfigure
# /usr/local/psa/admin/sbin/httpdmng --reconfigure-all
# /etc/init.d/nginx restart

56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c aea4cd7bfd353ad7a1341a257ad4724a 29d1e90fd304f01e6420fbe60f66f838 0a53c5a9ca65a74d37ef5c5eaeb55d7f 01bc4c8cf5b7f01f815a7ada004154a2 2a5151f57629129e26ff206d171fbb5f e335d9adf7edffca6a8af8039031a4c7 742559b1631652fadd74764ae8be475e

Email subscription for changes to this article
Save as PDF