Article ID: 114601, created on May 8, 2013, last review on May 29, 2015

  • Applies to:
  • Plesk 12.0 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux

Kennzeichen

Die FastCGI Anwendung und das Apache-Modul sind in der PHP-Unterstützung nicht aufgeführt (im Drop-down-Menü auf der Seite der Hosting-Einstellungen) . Hier ist lediglich die Option der CGI-Anwendung vorhanden.

Wodurch wird dieses Problem verursacht und wie behebe ich es?

Ursache

Plesk arbeitet im VPS-optimierten Modus:

# /usr/local/psa/bin/vps_optimized --status
 VPS Optimized mysql-innodb: off
 VPS Optimized apache-modules-all: on
 VPS Optimized apache-modules-except-php: off
 VPS Optimized apache-modules-except-scripting: off

In diesem Modus kann PHP nur als "CGI application" ausgeführt werden:

# /usr/local/psa/bin/domain --update example.com -php_handler_type module
 WARNING: mod_php is disabled because the Panel operates in the VPS-optimized mode.module is disabled because the Panel operates in the VPS-optimized mode.
 SUCCESS: Update of domain 'example.com ' completed.

# /usr/local/psa/bin/domain --update example.com  -php_handler_type fastcgi
 WARNING: mod_php is disabled because the Panel operates in the VPS-optimized mode.fastcgi is disabled because the Panel operates in the VPS-optimized mode.
 SUCCESS: Update of domain 'example.com ' completed.

Lösung

Schalten Sie Plesk in den normalen Betriebsmodus zurück, indem Sie die folgende SQL-Abfrage durchführen:

# mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa -e "update misc set val='0' where param='vps_optimized_mode_status';"

Einzelheiten hierzu finden Sie im Handbuch zur erweiterten Administration für Plesk 11 (EN).

56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 0a53c5a9ca65a74d37ef5c5eaeb55d7f 2a5151f57629129e26ff206d171fbb5f e335d9adf7edffca6a8af8039031a4c7 aea4cd7bfd353ad7a1341a257ad4724a 01bc4c8cf5b7f01f815a7ada004154a2

Email subscription for changes to this article
Save as PDF