Article ID: 117738, created on May 20, 2014, last review on Oct 21, 2014

  • Applies to:
  • Operations Automation
  • Virtuozzo 6.0
  • Virtuozzo hypervisor
  • Virtual Automation

Kennzeichen

Die VNC-Konsole für eine virtuelle Maschine in Parallels Virtual Automation ("PVA") oder im Parallels Power Panel ("PP") funktioniert nicht und gibt folgenden Fehler aus:

Network error: Socket is not connected

Ursache

Die VNC-Konsole in PVA / PP nutzt die Offline-Verwaltungstechnologie, um sich via VNC-Protokoll mit der virtuellen Maschine ("VM") zu verbinden. Damit dies funktioniert, müssen folgende Bedingungen erfüllt sein:

  • in der VM müssen die VNC-Einstellungen korrekt konfiguriert sein
  • in der VM muss der Offline-Dienst vzpp-desktop aktiviert sein
  • die VM muss über eine gültige Netzwerkkonfiguration verfügen
  • der Verbindungsaufbau zum Hardware Node über Port 4649 muss möglich sein
  • die VM im überbrückten Modus muss mit der Schnittstelle des Nodes verbunden sein, die vom Node selbst für die externe Kommunikation verwendet wird

Lösung

HINWEIS: Wenn in der VM noch keine Netzwerkkonfiguration besteht (z. B. wenn die VNC-Verbindung für die Installation eines Betriebssystems (OS) notwendig ist), müssen Sie den Offline-Dienst vzpp-desktop ganz deaktivieren (in den allgemeinen Einstellungen der VM). Dadurch wird die VNC-Verbindung direkt mit dem Hostserver von Parallels Cloud Server ("PCS") hergestellt, was Sicherheitsrisiken bergt, da das VNC-Protokoll allgemein unsicher ist. Sobald die OS-Installation abgeschlossen ist, können Sie vzpp-desktop wieder aktivieren.

  1. Vergewissern Sie sich, dass die VNC-Einstellungen für die virtuelle Maschine korrekt konfiguriert sind.

    Gehen Sie in PVA zu Infrastructure > Hardware Node > Virtual Machine > Configure > General Settings, erweitern Sie den Abschnitt "Remote Display" und überprüfen Sie, ob der Remote Display Service aktiviert ist.

    Dies kann aber auch über das Server-Back-End überprüft werden:

    ~# prlctl list -i -f <VM_NAME> | grep Remote
    

    Die korrekte Ausgabe sollte in etwa so aussehen:

    [root@host ~]# prlctl list -i -f test-vm | grep Remote
    Remote display: mode=auto address=0.0.0.0
    Remote display state: running
    

    So aktivieren Sie den Remote Display Service für die VM mit den Standardeinstellung:

    ~# prlctl set <VM_NAME> --vnc-mode auto --vnc-passwd <passwd>
    
  2. Vergewissern Sie sich, dass der Dienst vzpp-desktop aktiviert ist.

    Gehen Sie in PVA zu Infrastructure > Hardware Node > Virtual Machine > Configure > General Settings, erweitern Sie den Abschnitt "Offline Management" und wählen Sie eine dieser zwei Einstellungen:

    • Aktiviert mit den Standardeinstellungen
    • Aktiviert mit benutzerdefinierten Einstellungen, in denen 'Port 4649' ausgewählt ist

    Alternativ können Sie dies über das Server-Back-End mit diesem Befehl konfigurieren:

    ~# prlctl set <VM_NAME> --offline_management on --offline_service vzpp-desktop
    

    HINWEIS: Der Befehl in diesem Beispiel aktiviert nur den vzpp-desktop-Dienst. Wenn mehr Dienste konfiguriert werden müssen, sollten Sie sie alle, getrennt durch Kommas, auflisten.

  3. Vergewissern Sie sich, dass die Netzwerkeinstellungen für die virtuelle Maschine gültig sind und ihre IP-Adresse routingfähig ist. Testen Sie die Netzwerkverbindung zur VM von außerhalb des Hardware Node.

  4. Stellen Sie sicher, dass Port 4649 von Ihrem Standort aus erreichbar ist. Testen Sie die Verbindung mit üblichen Netzwerkdienstprogrammen. Sie können beispielsweise telnet nutzen:

    ~# telnet <node_ip_address> 4649
    

    Überprüfen Sie, ob Port 4649 auch tatsächlich über den Hardware Node kommuniziert:

    ~# netstat -ntlp | grep :4649
    

    Die korrekte Ausgabe lautet:

    [root@host ~]# netstat -ntlp | grep :4649
    tcp        0      0 0.0.0.0:4649                0.0.0.0:*                   LISTEN      536158/init
    tcp        0      0 :::4649                     :::*                        LISTEN      536158/init
    

    Wenn der Port 4649 nicht auf Kommunikation wartet, müssen Sie überprüfen, ob Folgendes gegeben ist:

    • Container 1 ist vorhanden und läuft:

      [root@host ~]# vzlist 1 -H
           1          3 running   192.168.161.108 -
      
    • Die Prozesse pvappd und pvaagentd werden ausgeführt:

      [root@host ~]# pvapp status
      pvappd (pid  196378) is running...
      [root@host ~]# pvaagent status
      pvaagentd (pid  195981) is running...
      
  5. die VM im überbrückten Modus muss mit der Schnittstelle des Nodes verbunden sein, die vom Node selbst für die externe Kommunikation verwendet wird.

    Der Server kann über mehrere Ethernet-Schnittstellen (physische NICs, VLANs usw.) verfügen und virtuelle Umgebungen können mit jeder beliebigen Schnittstelle verbunden werden. Dies kann zu ungleichförmigem Routing führen, wenn die VM mit einer Schnittstelle verbunden ist, die nicht für das Standard-Routing verwendet wird.

Wenn eine oder mehr der oben genannten Bedingungen nicht erfüllt sind, muss der Zustand des PVA Agent- und des PVA Power Panel-Dienstes überprüft werden. In diesem Fall kann der Artikel Problembehandlung bei Power Panel (VZPP) Problemen hilfreich sein.

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