Article ID: 1380, created on May 14, 2009, last review on May 11, 2014

  • Applies to:
  • Plesk 12.0 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux

Symptome

Sie erhalten eine Bounce-Nachricht wie die folgende, oder es finden sich ähnliche Fehler im Mail-Log:

<user@domain.tld>: Sorry. Although I'm listed as a best-preference MX or A for that host, it isn't in my control/locals file, so I don't treat it as local. (#5.4.6)

Ursache

Wenn eine Domain in Plesk eingerichtet wird, wird der Domainname zu den Dateien ...qmail/control/rcpthosts und ...qmail/control/virtualdomains hinzugefügt, um anzugeben, dass es sich dabei um eine lokale Domain handelt (Virtualdomain-Datei) und dass an sie gerichtete Nachrichten ohne Autorisierung (Datei rcpthosts) akzeptiert werden sollen.

Wenn der Fehler "I'm listed as a best-preference MX or A for that host, it isn't in my control/locals file" angezeigt wird, kann dies verschiedene Ursachen haben:

- die Domain existiert gar nicht in Plesk, aber der DNS-Server der Domain zeigt auf Ihren Server als MX-Server der Domain
- die Domain existiert, aber in der Plesk-Oberfläche wurde die Option domain.com > E-Mail > Deaktivieren gewählt
- die Domain existiert und wurde zu den oben genannten Dateien hinzugefügt, aber Qmail konnte danach nicht neu gestartet werden (Qmail liest diese Dateien nur während des Starts)
- die Domain existiert, wurde aber nicht zu den oben genannten Dateien hinzugefügt, weil während der Domaineinrichtung ein Fehler aufgetreten ist oder die Dateien manuell geändert wurden.

Lösung

Wenn die Domain in Plesk wirklich existiert und der E-Mail-Dienst für sie aktiviert ist, können Sie die Qmail-Konfigurationsdateien mit dem Tool /usr/local/psa/admin/sbin/mchk neu erstellen.

Der Fehler "listed as a best-preference MX" tritt meistens auf, wenn Systemmeldungen an Adressen wie root@hostname oder postmaster@hostname gesendet werden. Da die Domain "hostname" gewöhnlich nicht zu Plesk hinzugefügt wird, weiß Qmail nicht, wohin es verschiedene Systemberichte übermitteln soll. Diese Nachrichten blockieren dann die Warteschlange, bis sie verworfen werden. Eine einfache Methode zur Behebung dieser Situation ist die Einrichtung der Domain "hostname" in Plesk ohne Hosting und die Erstellung des E-Mail-Accounts root@ mit den Aliasen postmaster@, anonymous@, DrWEB-DAEMON@ etc. mit Umleitung an eine existierende Mailbox. Noch einfacher ist es, keine Mailbox oder Weiterleitungsoption für diesen Account zu aktivieren. In diesem Fall werden alle Nachrichten an den Account akzeptiert, aber unverzüglich verworfen.

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