Article ID: 1762, created on Feb 27, 2009, last review on May 10, 2014

  • Applies to:
  • Plesk 8.x for Linux/Unix

Symptome

Wenn Sie versuchen, das Paket libapache2-mod-php4 auf libapache-mod-php5 zu aktualisieren, versucht apt-get, das Paket psa gemäß der Abhängigkeitsliste von psa-php4-configurator mit allen Abhängigkeiten zu entfernen:

# apt-get install libapache2-mod-php5

    Reading Package Lists... Done (Paketlisten werden gelesen... Fertig)
    Building Dependency Tree... Done (Abhängigkeitsbaum wird aufgebaut... Fertig)
    Suggested packages (Empfohlene Pakete):
      php-pear
    The following packages will be REMOVED (Die folgenden Pakete werden ENTFERNT):
      libapache2-mod-php4 libpam-plesk psa psa-api psa-horde psa-hotfix3 psa-hotfix4 psa-hotfix5 psa-hotfix6     psa-imp psa-php4-configurator
    Die folgenden NEUEN Pakete werden installiert:
      libapache2-mod-php5

Lösung

Um dieses Problem zu beheben, müssen Sie auch das Paket psa-php5-configurator installieren:
# apt-get install psa-php5-configurator libapache2-mod-php5

Dieses Paket ist verfügbar im Plesk Debian-Repository unter 'dist-*/contrib/'.

Sie können es manuell von http://autoinstall.plesk.com/debian/PSA herunterladen oder das Debian-Repository konfigurieren:

deb http://autoinstall.plesk.com/debian/PSA_<Version> <Codename> all

Beispiel für Plesk 8.2.1 und Debian 4:

deb http://autoinstall.plesk.com/debian/PSA_8.2.1 etch all

b8ef5052d936e902043e41759118114e a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF