Article ID: 1770, created on Dec 6, 2011, last review on May 11, 2014

  • Applies to:
  • Plesk for Windows

Resolution

Dieser Artikel beschreibt Versionen von PHP, die in Plesk verwendet werden können sowie die empfohlene Konfiguration von php.ini-Dateien.

Es gibt zwei Versionen PHP, die in Plesk einbezogen sind und von Plesk unterstützt werden: PHP4 und PHP5. PHP kann in zwei Modi arbeiten: als CGI oder als ISAPI. Beide Versionen von PHP nutzen php.ini-Dateien, die je nach PHP-Version unterschiedlich sind.

Der standardmäßige Speicherort von php.ini für PHP4 ist das Windows Basisverzeichnis %systemroot%.

Der standardmäßige Speicherort von php.ini für PHP5 ist das PleskPHP5 Basisverzeichnis %plesk_dir%Additional\PleskPHP5.

Es kann auch eine benutzerdefinierte php.ini-Datei mit PHP4 im CGI-Modus verwendet werden. Um dies anzuwenden, muss die php.ini-Datei im Ordner /httpdocs abgelegt werden.

Diese Option besteht jedoch nicht, wenn PHP4 im ISAPI-Modus arbeitet, da dann immer die Standard-php.ini-Datei von PHP4 verwendet wird. Für PHP5 besteht die Möglichkeiten in beiden Modi nicht. Hier wird die Standard-php.ini-Datei von PHP5 genutzt.

Der standardmäßige Speicherort der php.ini-Datei in PHP5 wird durch den folgenden Wert in der Registry bestimmt:

HKEY_LOCAL_MACHINE\SOFTWARE\PHP\5\IniFilePath

Zusatzinformation

Wenn Sie weitere Informationen zu den Unterschieden zwischen den Modi ISAPI und CGI erhalten möchten, können Sie sich diesen Artikel durchlesen:

http://msdn2.microsoft.com/en-us/library/ms525172.aspx

85a92ca67f2200d36506862eaa6ed6b8 a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF