Article ID: 6302, created on Jun 5, 2009, last review on May 11, 2014

  • Applies to:
  • Plesk 9.2 for Linux/Unix

Symptome

Kaspersky Anti-Virus kann nicht über das Parallels Plesk Panel gestartet werden:

Module -> Kaspersky Anti-Virus: Kaspersky Anti-Virus-Engine - "Dienst starten"
 
Es wird folgende Fehlermeldung angezeigt:

An error occured while starting Kaspersky Anti-Virus Engine: the license information is missing or no license key was found at the path specified in the configuration file: Active key not found! (Beim Starten der Kaspersky Anti-Virus-Engine ist ein Fehler aufgetreten: die Lizenzinformation fehlt oder unter dem in der Konfigurationsdatei angegebenen Pfad wurde kein Lizenzkey gefunden: Aktiver Key nicht gefunden!)

Beim Starten von der Kommandozeile:

~# /etc/init.d/aveserver start
Could not load antiviral bases: [80000001] File not found
aveserver couldn't be started
~#

In der Logdatei erscheint folgende Meldung:

/var/log/kav/5.5/kav4mailservers/aveserver.log
---
[30/04/09 08:08:34 I] [30243] Kaspersky Anti-Virus server version 5.5.4 build #123 (RELEASE), using configuration file
/etc/kav/5.5/kav4mailservers/kavdaemon.conf
[30/04/09 08:08:34 A] [30243] 30.04.2009 08:08:34.961 4 KAV Licensing SDK [SUCCESS] CheckActiveKey succeeded for key:
[30/04/09 08:08:34 A] [30243] 30.04.2009 08:08:34.962 4 KAV Licensing SDK [SUCCESS] GetActiveKeyInfo succeeded for key:
[30/04/09 08:08:34 A] [30243] License file KAV009137790001.key, serial 09FA-0004B5-047CA8DF, "Kaspersky Anti-Virus for Plesk SWsoft International
Edition. 2 year License", expires 06/01/11 in 616 days
[30/04/09 08:08:35 W] [30243] You don't have enough network licenses for configured number of network clients. MaxClients reduced to 0
[30/04/09 08:08:35 I] [30243] Total license count: -1 local connections, and 0 network connections, will expire 04/01/11
[30/04/09 08:08:35 W] [30243] Cannot load information about available basesets, will use builtin defaults
[30/04/09 08:08:35 E] [30243] AV engine: Cannot open file /var/db/kav/5.5/kav4mailservers/bases/avp.set
[30/04/09 08:08:35 F] [30243] Could not load antiviral bases: [80000001] File not found
---


Es ist jedoch ein gültiger Lizenzkey für Kaspersky Anti-Virus in Parallels Plesk Panel als zusätzlicher Plesk-Lizenzkey installiert:

Plesk -> Lizenzverwaltung -> Zusätzliche Lizenzkeys: KAV001234560000

Und der Key ist im Verzeichnis KAV-Lizenzen vorhanden:

~# ls -l /var/db/kav/5.5/kav4mailservers/licenses/
total 12                                  
-rw-rw---- 1 kluser klusers 1712 Apr 30 07:44 KAV001234560000.key
-rw-r--r-- 1 root   root    1288 Apr 30 07:53 appinfo.dat
-rw-r--r-- 1 root   root     936 Apr 30 07:49 appinfo.kli
~#

Ursache

Die Datenbanken mit den Virusdefinitionen fehlen.

Lösung

Es wird empfohlen, zum Beheben des Problems die Datenbanken zu aktualisieren. Sie können dies über das Parallels Plesk Panel durchführen.
Melden Sie sich beim Control Panel als Administrator an und aktualisieren Sie die Datenbanken:

Module -> Kaspersky Anti-Virus: KeepUp2Date - "Click here to update virus definitions" (Hier klicken, um Virusdefinitionen zu aktualisieren)

Über den Button können die Virusdefinition-Datenbanken aktualisiert werden, die bei der Virenprüfung eingesetzt werden.
Sie können auch ein Intervall für die regelmäßige Aktualisierung der Anti-Virus-Datenbanken konfigurieren:

Module -> Kaspersky Anti-Virus -> KeepUp2Date: Update-Intervall

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