Article ID: 6310, created on Jun 1, 2009, last review on May 6, 2014

  • Applies to:
  • Plesk 9.x for Linux/Unix
  • Virtuozzo containers for Linux 4.0

Symptome

Das Ubuntu 7.10 EZ-Template kann nicht installiert werden, und es wird folgende Fehlermeldung angezeigt:

~# vzpkg install CTID plesk9
Err http://archive.ubuntu.com gutsy/main Packages
404 Not Found [IP: 91.189.88.140 80]
 ...

 
Dabei ist CTID die ID des Virtuozzo Containers, in dem die Applikation installiert wird.

Ursache

Das Problem wird dadurch verursacht, dass das Ubuntu-Repository 'http://archive.ubuntu.com/ubuntu/dists' in 'http://old-releases.ubuntu.com/ubuntu/dists/' geändert wurde.

Lösung

Führen Sie zum Beheben dieses Problems folgende Schritte durch:

1. Fügen Sie den neuen Verzeichnispfad zu der Datei /etc/vztt/url.map auf dem Hardware-Node hinzu.
Überprüfen Sie das aktuelle Repository:

~# grep UBU /etc/vztt/url.map
$UBU_SERVER     http://archive.ubuntu.com
~#

Fügen Sie den neuen Verzeichnispfad zu folgender Datei hinzu:

~# echo \$OLD_UBU http://old-releases.ubuntu.com >> /etc/vztt/url.map

2. Fügen Sie den geänderten Repository-Verzeichnispfad zu den 'repositories'-Dateien für Ubuntu 7.10 OS-Templates hinzu:

~# sed -i 's/UBU_SERVER/OLD_UBU/' /vz/template/ubuntu/7.10/x86_64/config/os/default/repositories
~# sed -i 's/UBU_SERVER/OLD_UBU/' /vz/template/ubuntu/7.10/x86/config/os/default/repositories

3. Aktualisieren Sie den Template-Cache mit den folgenden Befehlen:

~# vzpkg update cache -r ubuntu-7.10-x86
~# vzpkg update cache -r ubuntu-7.10

35c16f1fded8e42577cb3df16429c57a d02f9caf3e11b191a38179103495106f e8e50b42231236b82df27684e7ec0beb 6ef0db7f1685482449634a455d77d3f4 a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 2897d76d56d2010f4e3a28f864d69223 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF