Article ID: 6561, created on Jan 7, 2010, last review on May 6, 2014

  • Applies to:
  • Plesk 9.x for Linux/Unix
  • Plesk 8.6 for Linux/Unix

Symptome

Nach der Aktualisierung des Internet Explorer-Browsers auf die Version 8.0 auf einer Client Workstation kann die Oberfläche von Parallels Plesk Panel nicht mehr geöffnet werden.


Grund


IE8 funktioniert einwandfrei im kompatiblen Modus mit den Versionen Plesk 7, 8 und 9, da diese Versionen Parallels Plesk Panel vor IE8 veröffentlicht wurden. IE8 wird in den Folgeversionen von Parallels Plesk Panel im 'nativen Modus' unterstützt werden.

Lösung

Plesk 8.6:

Eine mögliche Zwischenlösung für das Problem wird in diesem Artikel beschrieben.

Modifizieren Sie die config-Datei "/opt/psa/admin/conf/httpsd.conf' or  '/usr/local/psa/admin/conf/httpsd.conf' abhängig von Ihrer "Parallels Plesk Panel"-Installation und fügen Sie die folgenden Strings in dieser Datei ein, wodurch IE8 gezwungen wird, IE7-Rendering zu verwenden:

LoadModule headers_module libexec/mod_headers.so
Header set X-UA-Compatible "IE=EmulateIE7"

Starten Sie anschließend den Plesk-Dienst neu, damit die Änderungen wirksam werden:

~# /etc/init.d/psa restart


Plesk 9.x:



Da Plesk 9.x das Paket 'lighttpd' verwendet, müssen folgende Änderungen übernommen werden:

Bearbeiten Sie die Konfigurationsdatei des Plesk Control Panel-Diensts '/etc/sw-cp-server/applications.d/plesk.conf':

1) Fügen Sie "mod_setenv" zu der Liste mit den Modulen hinzu:

Zu modifizierender String:
server.modules += ("mod_expire", "mod_fastcgi", "mod_rewrite", "mod_accesslog", "mod_alias", "mod_compress")

Nach der Modifikation:
server.modules += ("mod_expire", "mod_fastcgi", "mod_rewrite", "mod_accesslog", "mod_alias", "mod_compress","mod_setenv")

2) Anschließend müssen die Plesk CP virtuellen Hosts in derselben Konfigurationsdatei verändert werden. Fügen Sie die folgende Zeile hinzu: "setenv.add-response-header = ( "X-UA-Compatible" => "IE=EmulateIE7" )"

Beispiel:

Vor der Modifikation:

...
$SERVER["socket"] == ":8443" {
  include_shell "/usr/local/psa/admin/conf/ssl-conf.sh"
...
$SERVER["socket"] == ":8880" {
  index-file.names = ("index.php")
...



Nach der Modifikation:

...
$SERVER["socket"] == ":8443" {
  setenv.add-response-header = ( "X-UA-Compatible" => "IE=EmulateIE7" )
  include_shell "/usr/local/psa/admin/conf/ssl-conf.sh"
...
$SERVER["socket"] == ":8880" {
  setenv.add-response-header = ( "X-UA-Compatible" => "IE=EmulateIE7" )
  index-file.names = ("index.php")
...

Um diese Änderungen zu übernehmen, starten Sie bitte den Dienst 'sw-cp-server' neu:

~# /etc/init.d/sw-cp-server restart
Restarting SWsoft control panels server... stale pidfile. [ OK ]

b8ef5052d936e902043e41759118114e a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 6ef0db7f1685482449634a455d77d3f4 9fa0130c84cac4b292697ade62270a40 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF