Article ID: 8623, created on Jan 8, 2013, last review on Aug 12, 2014

  • Applies to:
  • Plesk

Kennzeichen

Es ist nicht möglich, Zugang zu Parallels Plesk Panel zu erhalten. Der Browser zeigt einen der folgenden Fehler an:

FEHLER: SWKeyExFatalError

xmlrpc error: XML parsing failed

Zusammen mit einem solchen Stack-Trace:

0: common_func.php3:4523
of_get_key_by_product(string 'plesk-win')
1: common_func.php3:4523
getPleskKey()
2: common_func.php3:4602
getKeyProp(string 'demo')
3: auth.php3:54

Ursache

Der oben genannte Fehler deutet darauf hin, dass entweder die Datei %plesk_dir%\admin\repository\registry.xml oder ( bzw. und) eine der Lizenzschlüsseldateien aus %plesk_dir%\admin\repository\keys\ beschädigt ist (sind).

Lösung

Löschen oder benennen Sie die Datei '%plesk_dir%\admin\repository\registry.xml' um und versuchen Sie erneut, Zugang zu Parallels Plesk Panel zu erhalten. Es sollte automatisch eine neue Datei erstellt worden sein.

Sollte dies das Problem nicht beheben, könnten eine oder mehrere Lizenzschlüsseldateien aus '%plesk_dir%\admin\repository\keys\' beschädigt sein. In dem Fall können Sie versuchen, folgenden Algorithmus zu verwenden, um das Problem zu beheben:

  1. Überprüfen Sie den Inhalt des Ordners '%plesk_dir%\admin\repository\keys'. Er enthält nur eine Lizenzschlüsseldatei, sehr wahrscheinlich die Parallels Panel Hauptlizenz. Sollte Sie beschädigt sein (falsche XML-Syntax oder die Datei ist leer), müssen Sie eine gültige Datei von Ihrem Anbieter erhalten und sie mithilfe folgenden Befehls installieren:

    "%plesk_bin%\keymng.exe" --install --source-file=<pfad_zur_datei>
    

    Nun sollte Parallels Plesk Panel funktionieren.

  2. Falls es mehrere Lizenzdateien gibt, müssen Sie herausfinden, welche davon die Parallels Panel Hauptlizenzdatei ist. Sie enthält in etwa Folgendes:

    <core:description>
    <core:keytype>Parallels Plesk Panel 10.x/11.x and Later for Windows </core:keytype>
    
    
    <core:product core:type="string">plesk-win</core:product>
    

    Belassen Sie nur die Parallels Panel Hauptlizenzdatei im Verzeichnis '%plesk_dir%\admin\repository\keys\' und überprüfen Sie, ob Sie sich bei Parallels Plesk Panel anmelden können. Wenn nicht, fahren Sie mit Punkt eins fort.

  3. Melden Sie sich am Parallels Panel an und klicken Sie auf 'Schlüssel abrufen' im Bereich "Tools & Einstellungen > Lizenz". Dadurch werden alle zusätzlichen Schlüssel automatisch von KA abgerufen (sofern keine Verbindungsprobleme mit dem KA-Server auftreten). Sollte es Probleme geben, lesen Sie bitte folgenden Artikel: http://kb.sp.parallels.com/de/808

a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF