Article ID: 9388, created on Nov 27, 2012, last review on May 9, 2014

  • Applies to:
  • Virtuozzo 6.0
  • Virtuozzo hypervisor

Symptome

Die Installation von Parallels Tools wird rückgängig gemacht, ohne dass eine Fehlermeldung zurückgegeben wird.

Um die Ursache des Rollbacks zu ermitteln, müssen Sie die Logdatei unter C:\Windows\Temp\parallels-tools-setup.log öffnen. Die Datei enthält die folgende Zeichenfolge:

 

Beispiel:


Hinweis: Die hier gezeigte Komponente "prl_dd.inf_x86_neutral_caed5e8e38ace253" ist lediglich ein Beispiel. Sie müssen die Datei parallels-tools-setup.log überprüfen, um die Komponente genau zu ermitteln, die in Ihrem Fall nicht installiert werden kann.

Ursache

Eine oder mehrere Dateien, die den Cache für Parallels-Treiber enthalten, sind infolge eines nicht ordnungsgemäßen Herunterfahrens oder eines Absturzes der virtuellen Maschine während der Installation von Parallels Tools beschädigt.

Lösung

HINWEIS: Es wird dringend empfohlen, ein Backup Ihrer virtuellen Maschine zu erstellen, bevor Sie mit diesen Anweisungen fortfahren.

Abschnitt 1.

  • Aktualisieren Sie Ihr Windows 7 auf Windows 7 Service Pack 1.
  • Starten Sie Windows neu und überprüfen Sie, ob das Problem weiterhin besteht. Falls ja, fahren Sie mit Abschnitt 2 fort.

Abschnitt 2.

  • Entfernen Sie Parallels Tools über das Control Panel.
  • Starten Sie Windows in Ihrer virtuellen Maschine neu.
  • Installieren Sie Parallels Tools über das Parallels Desktop-Menü (Virtuelle Maschine -> Parallels Tools installieren) erneut.
  • Falls das Problem weiterhin besteht, gehen Sie zu Abschnitt 3.

Abschnitt 3.

  • Öffnen Sie den Ordner C:\Windows\System32\DriverStore\FileRepository.
  • Suchen Sie den Ordner prl_dd.inf_x86_neutral_caed5e8e38ace253. Den genauen Namen finden Sie in der Logdatei (siehe Beispiel oben).
  • Ändern Sie die Berechtigungen für den Ordner C:\Windows\System32\DriverStore\FileRepository\prl_dd.inf_x86_neutral_caed5e8e38ace25. Wählen Sie Administratoren aus und gewähren Sie Vollzugriff (klicken Sie mit der rechten Maustaste auf den Ordner, und wählen Sie Eigenschaften -> Sicherheit).
  • Entfernen Sie diesen Ordner.
  • Installieren Sie Parallels Tools über das Parallels Desktop-Menü (Virtuelle Maschine -> Parallels Tools installieren) erneut.

Wenn Sie eine virtuelle Maschine für Windows 7 haben und keine dieser Lösungen bei Ihnen funktioniert hat, gehen Sie bitte folgendermaßen vor:

  • Diese Lösung funktioniert nur, wenn der Fehler in der Logdatei vorhanden ist:
  • Öffnen Sie den Ordner C:\Windows\System32\DriverStore.
  • Suchen Sie die Dateien infstor.dat, infstrng.dat und INFCACHE.1.
  • Ändern Sie die Berechtigungen für diese Dateien: klicken Sie mit der rechten Maustaste auf jede der Dateien, wählen Sie Eigenschaften -> Sicherheit, wählen Sie Administratoren und gewähren Sie Vollzugriff.
  • Benennen Sie die Dateien um (zum Beispiel in "1infstor.dat").

          Hinweis: Das Umbenennen der Dateien infstor.dat, infstrng.dat und INFCACHE.1 ist eine temporäre Umgehungsmöglichkeit. Benennen Sie sie nicht um, wenn Ihr Problem durch die Lösung in Abschnitt 1 oder 2 behoben wurde.
          WICHTIG: Entfernen Sie nicht die oben angegebenen Dateien, da dies zur Anzeige der BSOD-Fehlermeldung in Ihrer virtuellen Maschine führen kann.

  • Installieren Sie Parallels Tools über das Parallels Desktop-Menü (Virtuelle Maschine -> Parallels Tools installieren) erneut.

2897d76d56d2010f4e3a28f864d69223 a26b38f94253cdfbf1028d72cf3a498b 0dd5b9380c7d4884d77587f3eb0fa8ef c62e8726973f80975db0531f1ed5c6a2

Email subscription for changes to this article
Save as PDF