Article ID: 10066, created on Mar 11, 2011, last review on May 11, 2014

  • Applies to:
  • Plesk 10.x for Windows

Symptoms

This issue relates to upgrading from Parallels Plesk Panel 10.x.x to Parallels Plesk Panel 10.x.x when the initial upgrade to Parallels Plesk Panel 10 is from Parallels Plesk Panel 8.x or 9.x. The key indicator of this issue is an error message in autoinstaller3.log during the upgrade from Parallels Plesk Panel 10.x.x to Parallels Plesk Panel 10.x.x:

Application: {E195DC26-A6B4-4E13-B8E9-D61B43997DDD}
Command line: UPGRADINGPRODUCTCODE={F8D82C03-89D1-4BA3-B9E0-303C0225F37B}  CLIENTUILEVEL=3 REMOVE=ALL
.......
MSI: The system cannot find the file specified. (Error code 2) at Unable to connect to pipe \\.\pipe\psapipe
MSI: Error! The system cannot find the file specified. (Error code 2) at Unable to connect to pipe \\.\pipe\psapipe
MSI: Action ended 9:19:07: CheckInstallConditions. Return value 3.
MSI: Action ended 9:19:07: INSTALL. Return value 3.

{E195DC26-A6B4-4E13-B8E9-D61B43997DDD}
 is the ProductCode of Parallels Plesk Panel 8.x/9.x. It is not removed completely during the upgrade from Parallels Plesk Panel 8.x/9.x to Parallels Plesk Panel 10.x.

Resolution

Parallels Plesk Panel 8.x/9.x should be removed from MSI DB in the registry, i.e., remove these keys after upgrading to Parallels Plesk Panel 10.x:
HKEY_CLASSES_ROOT\Installer\Products\62CD591E4B6A31E48B9E6DB13499D7DD
HKEY_CLASSES_ROOT\Installer\UpgradeCodes\6A3FF024D3FF40B49A2F98B66229FE7B

A record in Add/Remove Programs about Parallels Plesk Panel 8.x/9.x may also exist, and should be removed in this case:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{E195DC26-A6B4-4E13-B8E9-D61B43997DDD}

The upgrade should then be repeated by the autoinstaller.

c796c01d6951fa24ed54c7f1111667c6 a914db3fdc7a53ddcfd1b2db8f5a1b9c 85a92ca67f2200d36506862eaa6ed6b8 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF