Article ID: 111137, created on Apr 14, 2011, last review on Dec 10, 2014

  • Applies to:
  • Virtuozzo containers for Windows 4.6

Symptoms

The entire hardware node becomes unresponsive every 30 - 60 minutes for prolonged periods of time (from several minutes to an hour). After the node becomes available again, you can see the following messages in virtuozzo.log related to shrinking, that span the entire lockup period:

{0000000000000000\}; T=2009.02.25 10:30:12.359; A=VzSrv; P=1872.1900; S=VZSRV; F=build\\4.0.427.0\\sources\\virtuozzo\\vzwin\_11\\vzmain\\vzsrv\\shrink.c,shrinkPrepareVps,328; L=NOTICE; R=87(135); C=0(0); M=135 [] selected: CTID 154 disk C: size=107374182400, free=48231417856, image size=92836857344
{0000000000000000\}; T=2009.02.25 10:30:12.484; A=VzSrv; P=1872.1900; S=VZSRV; F=build\\4.0.427.0\\sources\\virtuozzo\\vzwin\_11\\vzmain\\vzsrv\\shrink.c,shrinkDisk,428; L=INFO; R=87(135); C=0(0); M=135 [] shrink started: CTID 154 disk C:
{0000000000000000\}; T=2009.02.25 10:30:12.484; A=VzSrv; P=1872.1900; S=VZSRV; F=build\\4.0.427.0\\sources\\virtuozzo\\vzwin\_11\\vzmain\\vzsrv\\shrink.c,shrinkProcess,470; L=NOTICE; R=87(135); C=0(0); M=135 [] processing 1 disk(s)
{0000000000000000\}; T=2009.02.25 10:30:22.484; A=VzSrv; P=1872.1900; S=VZSRV; F=build\\4.0.427.0\\sources\\virtuozzo\\vzwin\_11\\vzmain\\vzsrv\\shrink.c,shrinkProcess,470; L=NOTICE; R=87(135); C=0(0); M=135 [] processing 1 disk(s)
{0000000000000000\}; T=2009.02.25 10:30:32.484; A=VzSrv; P=1872.1900; S=VZSRV; F=build\\4.0.427.0\\sources\\virtuozzo\\vzwin\_11\\vzmain\\vzsrv\\shrink.c,shrinkProcess,470; L=NOTICE; R=87(135); C=0(0); M=135 [] processing 1 disk(s)

Cause

This issue is caused by the shrinking process of some containers' hard disk, which generates many disk I/O operations, thus significantly increasing the latency of all user operations.

The issue only occurs when the container's hard disk is:

  1. of compact type (as distinct from plain).
  2. very large (close to 100 GB or more).
  3. significantly fragmented.

Resolution

Our development team is working on a permanent solution to the problem.

Two workarounds are available:

  1. Switch the container's disk type to "plain." The disk will occupy the same amount of space on the host system as its actual size. Shrinking is not performed for such disks.

  2. Disable automatic disk shrinking and perform disk shrinking manually during maintenance hours. Keep in mind that the node might become unavailable for a long period of time with this option.

In order to disable automatic disk shrinking, open the Registry Editor (regedit) on the hardware node and look for key HKLM\SOFTWARE\SWSoft\Virtuozzo\Shrink registry key. SleepTime is the time interval between automatic shrink runs. By default, SleepTime is set to 1800 seconds. Reset SleepTime to the maximum value allowed and reboot the hardware node.

After resetting the SleepTime value, you may use following command to perform shrinking manually:

C:\>vzctl shrink <CTID> --drive <CT_drive_name>

Note: <CTID> and <CT_drive_name> should be replaced with the actual container ID and its hard disk drive name.

Using this command you can automate shrinking with the Windows Task Scheduler at the desired time.

Notes:

  1. Do not forget that the hardware node may freeze for a long period of time during this operation. If you automate this task with Windows Task Scheduler, Parallels recommends that you select a low-usage time for the task, such as 4:00 am on a Saturday morning.
  2. Physical disk maintenance with Windows OS tools, like Disk Defragmenter and Disk Cleanup will also enhance your server’s I/O capability. Parallels recommends that you routinely and automatically maintain your physical disk media on Windows platforms. Please consult with Microsoft for best disk maintenance practices.

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