Article ID: 11154, created on Mar 22, 2011, last review on Jun 17, 2016

  • Applies to:
  • Virtuozzo containers for Windows 4.6

Symptoms

I installed Service Pack 1 for Windows Server 2008 R2 on the hardware node, rebooted the server. Now containers are not running and the system event log contains the following errors:

    The vzktech service failed to start due to the following error:
    A device attached to the system is not functioning.

and

    The vzcore service depends on the vzktech service which failed to start because of the following error:
    A device attached to the system is not functioning.

Resolution

Upgrade to Service Pack 1 for Windows Server 2008 R2 is not supported by Virtuozzo containers 4.6 and needs to to be uninstalled from the node. Refer to the following KB article:

10051 Does Virtuozzo containers 4.6 support Windows Server 2008 R2 Service Pack 1?

Not all Windows 2008R2 SP1 editions and locales are supported by Virtuozzo containers for Windows. For more information refer to this article:

113610 Windows 2008R2 SP1 locales and editions supported by Virtuozzo containers for Windows

Search Words

vzktech

The vzktech service failed to start

Service Pack 1

there is no parallels container installed

installed SP1

The vzcore service depends on the vzktech service which failed to start

windows 2008r2sp1

vzktech failed

vzktech error

A device attached to the system is not functioning

install service pack

parallels installed unsupported windows updates, lingering issues with containers

vzktech service failed

windows update

install service pack 1

Parallels Container Management System not starting after Windows updates

windows 2008 r2 sp1

vzktech service error

service pack

Upgrade to Service Pack 1

6c20476fe6c3408461ce38cbcab6d03b d02f9caf3e11b191a38179103495106f 965b49118115a610e93635d21c5694a8 2897d76d56d2010f4e3a28f864d69223

Email subscription for changes to this article
Save as PDF