Article ID: 111566, created on Jun 30, 2011, last review on Aug 11, 2016

  • Applies to:
  • Plesk for Linux/Unix


How to install Kaspersky Antivirus version 8 for Plesk for Linux 9.5.4 or older?


Applicable to:

Plesk 9.5.4 on:

  • CentOS 4, 5
  • RHEL 4, 5, 6
  • CloudLinux 5
  • Debian 5
  • SLES 10
  • Ubuntu 6, 8, 10

Plesk 9.3.0 on:

  • CentOS 4
  • CentOS 5
  • Debian 5
  • RHEL 4
  • RHEL 5
  • SLES 10
  • Ubuntu 6.06
  • Ubuntu 8.04

Plesk 8.6.0 on:

  • CentOS 4,
  • RHEL 4, 5
  • Ubuntu 8

Before switching to the Kaspersky Antivirus 8, it is strongly recommended to create a fresh dump of bases and configuration. This method will allow to easily switch back to the old version of Kaspersky if necessary:

# cp -f /etc/kav/5.5/kav4mailservers/kav4mailservers.conf /var/lib/psa/dumps/
# mysqldump -uadmin -p`cat /etc/psa/.psa.shadow` --quote-names psa module_kav_groups module_kav_parameters module_kav_mailnames | gzip > /var/lib/psa/dumps/kav_db_dump.gz

For a RPM-based OSes configuration, the dump of bases should be automatically stored to the following directory:\{$DUMP\_D\}/kav\_201107011141/. DUMP\_D is usualy /var/lib/psa/dumps. For deb-based OSes, you should create a dump of bases and configuration manually.

With autoinstaller:

Install the Kaspersky antivirus version 8 component for Plesk 9.5.4. The release is located in the Additional mail services group.

With EZ templates:

  1. As the root on the Hardware Node, run:

    vzpkg update

    for example:

    vzpkg update 664 plesk9.5-kav plesk9.5-postfix plesk9.5-watchdog plesk9.5)


    vzpkg update - it will also update installed system packages.

  2. Run the following command:

    vzpkg install plesk9.5-kav8`

plesk9.5-kav8 template can be found here in the templates for Plesk 9.5 section.

After the installation is complete, install Kaspersky license:

Home > Settings > License Management > Additional License Keys

Then, select "Kaspersky AntiVirus" as the used antivirus in:

Home > Server-wide mail preferences

Note: Kaspersky Antivirus 8 will not work with if selinux enforced: Selinux blocks Kaspersky Antivirus work

Switching back to the module is described in the following article: How to switch back to Kaspersky antivirus module from Kaspersky antivirus version 8.

Additional information

Additional information for upgrading to Kaspersky Antivirus 8:

  • you will not be able switch on server-wide checking, but all those mailboxes that were checked in a certain direction before switching will continue to be checked.
  • all custom settings on Kaspersky Antivirus (server-wide or per mailbox behavior for different file types, logs detalization, notifications, period of bases updating, etc.) will be switched to default settings and you will not have the possibility to manage it in the new Kaspersky Antivirus version.
  • If you will install the old psa-kav module with Parallels Plesk Panel on RHEL 6, then the new Kaspersky Antivirus 8 (psa-kav8) will be installed anyway.
  • if you try to upgrade to Parallels Plesk Panel 10.0.1 upgrade will fail, upgrade to latest Plesk version.
  • If you meet performance degradation after installing Kaspersky Antivirus 8, read the following article carefully: Performance degradation if Kaspersky Antivirus 8 installed on server with Plesk 10

Search Words

kaspersky update failed

kaspersky 5 is no longer supported

File does not exist on source 'index/master.xml'

cannot update virus definitions any more

a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF