Article ID: 111662, created on Jul 18, 2011, last review on Aug 12, 2014

  • Applies to:
  • Plesk for Linux/Unix
  • Plesk for Windows

Updating from an earlier Parallels Plesk Panel 10.x version


If you are updating to Parallels Plesk Panel 10.3 from an earlier Parallels Plesk Panel 10.x version, you will not need to change/upgrade your license.

Your Parallels Plesk Panel 10.x license will work on the 10.0, 10.1, and 10.3 installation.

Upgrading from a previous Parallels Plesk Panel version



If you are upgrading to Parallels Plesk Panel 10.3 from Parallels Plesk Panel 9.5 and earlier versions, you will need to upgrade your license or purchase a new Parallels Plesk Panel 10.3 license.

A valid Lease license for Parallels Plesk Panel can be upgraded to Parallels Plesk Panel version 10.3 at no additional cost.

If you have a Retail Parallels Plesk license, your license can be upgraded to Parallels Plesk Panel 10.3 as long as it has a valid Software Update Service (SUS).

If the Software Update Service on your license has already expired, you may Reinstate it. Alternatively you may lease/purchase a new Parallels Plesk Panel 10.3 license

a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 85a92ca67f2200d36506862eaa6ed6b8 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF