Article ID: 111815, created on Aug 5, 2011, last review on May 5, 2014

  • Applies to:
  • Virtuozzo for Linux 3.x

Resolution

The following resources may help you to perform an upgrade from Parallels Virtuozzo Container for Linux 3.0 and 3.0 SP1 to the newer versions:

Parallels Virtuozzo Containers for Linux 3.0 and 3.0 SP1 and Parallels Virtual Automation 3.0 End of Life Policy Statements:

Parallels Virtuozzo Containers for Linux 3.0 End of Life (EOL) Policy Statement

Parallels Virtual Automation 3.0 End of Life (EOL) Policy Statement

Answer the following three questions to choose the best upgrade path for your needs:

  1. Is your host operating system supported by newer versions of Parallels Virtuozzo Containers?

    Host OS versions supported by Parallels Virtuozzo Containers for Linux

    If not supported: Consider following one of the options listed below:

    a. Use online migration to move containers from the host to a server running Parallels Virtuozzo Containers for Linux 4.6 or 4.0.
    b. Use offline migration to move containers from the host to a server running Parallels Virtuozzo Containers for Linux 4.7
    c. Reinstall the system with a new operating system and Parallels Virtuozzo Containers for Linux 4.7 keeping /vz directory.
    

    Refer to this article in case of problems during migration: I cannot migrate VE to another node. How do I solve it?

    Refer to this article in case you are using the migration feature in POA: How to use the "Migration to PVC 4.x" feature in POA

    Refer to this article for in-place upgrade instructions: Upgrading Parallels Virtuozzo Containers 3.0 for Linux on CentOS 4 to Parallels Containers 4.7 on CentOS 6.x

    If supported: continue reading to check other possible upgrade paths.

  2. Are there any containers using standard templates on the node?

    If yes: The best choice would be either to migrate such containers to Parallels Virtuozzo Containers for Linux 4.7, 4.6, or 4.0 host or to upgrade the node directly to version 4.7.

    Upgrading to Parallels Virtuozzo Containers 4.0, page 3

    Upgrading to Parallels Virtuozzo Containers 4.6, page 8

    Upgrading to Parallels Virtuozzo Containers 4.7, page 8

    If there are no containers based on standard templates, there are no limitations for upgrades.

    NOTE: Consider backwards compatibility limitations before the upgrade:

    Upgrading to Parallels Virtuozzo Containers 4.0, page 8

    Upgrading to Parallels Virtuozzo Containers 4.6, page 12

    Upgrading to Parallels Virtuozzo Containers 4.7, page 12

  3. Is VZAgent API 3.0 compatibility required?

    The latest versions of all Parallels Automation software (PVA, POA, PBA-S) work with Parallels Virtuozzo Containers in native mode and normally, compatibility with version 3.0 is not required. For detailed information about VZagent API compatibility, refer to article VZagent API compatibility (Linux)

    If VZAgent 3.0 API compatibility mode is still required, refer to article How to configure PVC node to be compatible with Virtuozzo 3.x

    If VZAgent 3.0 API compatibility is not required, simply upgrade to the latest version of Parallels Virtuozzo Containers for Linux available.

Additional information

Version 4.7 would be the most preferable upgrade version. In case you upgrade to Parallels Virtuozzo Containers, version 4.0 or 4.6 is required use the following resources to obtain full distribution of the desired version:

How to download full distribution of Parallels Containers for Linux

How to install a specific version of Parallels Containers for Linux

Search Words

upgrade Virtuozzo

e8e50b42231236b82df27684e7ec0beb 2897d76d56d2010f4e3a28f864d69223 d02f9caf3e11b191a38179103495106f 9b9439294978ca011521bd467a069524

Email subscription for changes to this article
Save as PDF