Article ID: 112394, created on Sep 28, 2011, last review on May 10, 2014

  • Applies to:
  • Virtuozzo containers for Linux 4.7


While trying to mount an NFS share from within a container based on the Debian 6.0 OS template, the following error is returned:
# mount -t nfs /mnt
mount.nfs: an incorrect mount option was specified


Utility mount.nfs requires special capabilities from Linux kernel, which are not available in the kernels 2.6.18-028stabNNN compatible with PVC 4.0 and 4.6 versions. In order to use this utility, run containers on PVC 4.7 with the kernel 2.6.32-042stabNNN or import mount.nfs binary from Debian 5.0, CentOS 5, or other similar distributions. The easiest way in the latter case would be to copy this utility from the host node.

0c05f0c76fec3dd785e9feafce1099a9 d02f9caf3e11b191a38179103495106f e8e50b42231236b82df27684e7ec0beb 2897d76d56d2010f4e3a28f864d69223

Email subscription for changes to this article
Save as PDF