Article ID: 11240, created on Apr 6, 2011, last review on Apr 17, 2012

  • Applies to:
  • Plesk 10.2 for Linux/Unix


After you have upgraded Parallels Plesk Panel 10.0.x Virtuozzo template to Parallels Plesk Panel 10.2 with command vzpkg update and stated the initial Plesk configuration, you encountered the following error:

PHP Fatal error: Class kavInterface contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (VirusFilter::available) in /usr/local/psa/admin/plib/modules/kav/kavInterface.php on line 59


Kaspersky antivirus package was not properly upgraded.


Upgrade Kaspersky antivirus package manually with this command:
# vzpkg install <CT ID> -p psa-kav psa-kav8

d3c493291d6d9f66837ac7495dfea9ca a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 dd0611b6086474193d9bf78e2b293040 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF