Article ID: 112572, created on Oct 20, 2011, last review on Aug 12, 2014

  • Applies to:
  • Plesk 10.x for Linux
  • Plesk 9.x for Linux/Unix


The version of PHP installed on the server does not match the requirements for the web application. During the application installation, the following error is displayed:
Error: This application cannot be installed because its installation requirements are not met. Contact your hosting provider to resolve this issue.


Plesk Panel cannot correctly detect the two-digit version numbers of an application. For example, PHP version 5.2.13 is interpreted as "5.2.1" and would not be accepted during Drupal application installation, which requires version 5.2.4 or higher.


Plesk 10.x: this issue has been resolved permanently in Parallels Plesk Panel 10.3. The recommended solution is to upgrade your installation.

Plesk 9.5: Consider upgrading your installation to version 9.5.4 and replace the file ${PRODUCT_ROOT_D}/admin/htdocs/plib/SiteApps/class.SiteAppMetaDataReader.php with the fixed version from the attached archive.


a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 6ef0db7f1685482449634a455d77d3f4 dd0611b6086474193d9bf78e2b293040 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF