Article ID: 113105, created on Jan 10, 2012, last review on Sep 15, 2014

  • Applies to:
  • Virtuozzo containers for Linux 4.7

Symptoms

Unable to install Parallels Virtuozzo Containers for Linux 4.7 on CentOS 6.1 or a newer version using autoinstaller:
[root@localhost /]# ./vzinstall-linux-x86_64.bin install
Downloading index files...
Checking system requirements...
Checking for system platform.............................................Linux
Checking for system architecture........................................x86_64
Checking for available Virtuozzo............................Virtuozzo 4.7.0-99
Checking for hardware support...............................................ok
Checking for OS distribution............................................failed
  Your computer is running
  CentOS release 6.2 (Final)
  which is not supported by Virtuozzo. The supported OS
  distributions are the following:
      RHEL 4
      RHEL 5
      RHEL 6
      CENTOS 4
      CENTOS 5
      CENTOS 6
      SLES 10
Virtuozzo Autoinstall cannot proceed due to the above problems.
Please solve them and restart Virtuozzo Autoinstall.


Also installation may give an error on a later stage:
+---------------------| Dependency conflict |---------------------+
|                                                                 |
| Installing Parallels Virtuozzo Containers on your system        |
| will cause dependency conflicts listed below. This              |
| happens when installing Parallels Virtuozzo Containers          |
| on unsupported Linux distribution.                              |
|                                                                 |
| libstdc++.so.5()(64bit) is needed by vzup2date-4.7.0-6.x86_64   |
| libstdc++.so.5(CXXABI_1.2)(64bit) is needed by                  |
| vzup2date-4.7.0-6.x86_64                                      # |
| libstdc++.so.5(GLIBCPP_3.2)(64bit) is needed by               # |
| vzup2date-4.7.0-6.x86_64                                      # |
| libstdc++.so.5(GLIBCPP_3.2.2)(64bit) is needed by               |
|                                                                 |
|          +--------+   +-----------+   +-------+                 |
|          | Skip   |   | Try again |   | Abort |                 |
|          +--------+   +-----------+   +-------+                 |
|                                                                 |
|                                                                 |
+-----------------------------------------------------------------+

Cause

Parallels Virtuozzo Containers for Linux 4.7 autoinstaller (4.7-99) was tested with the latest version of CentOS (version 6.0) available at the moment of the release.

Changes made to CentOS in versions 6.1 and 6.2 caused the installation issue. 

Resolution

To install PVCfL 4.7 on CentOS 6.1 and newer versions, perform the following steps:
1. Download and unpack the full distribution of PVCfL 4.7 from this article.

2. Locate and install the compat package:
/vz/distr/virtuozzo/compat/RHEL5/compat-libstdc++-33-3.2.3-61.x86_64.rpm

3. Re-launch the autoinstaller.

0c05f0c76fec3dd785e9feafce1099a9 d02f9caf3e11b191a38179103495106f e8e50b42231236b82df27684e7ec0beb 2897d76d56d2010f4e3a28f864d69223

Email subscription for changes to this article
Save as PDF