Article ID: 113424, created on Mar 6, 2012, last review on Aug 12, 2014

  • Applies to:
  • Plesk 10.x for Linux
  • Plesk 9.x for Linux/Unix
  • Plesk 8.x for Linux/Unix
  • Plesk 10.x for Windows
  • Plesk 9.x for Windows
  • Plesk 8.x for Windows

Release notes

The plesk_remote_vulnerability_checker.php allows Plesk owners to find out if their server with Plesk Panel 8.x, 9.x, 10.0, 10.1, 10.2, or 10.3 is vulnerable.

[download the script]

Change the directory to the one where you downloaded the script and run the command below to launch it.

# php -d safe_mode=0 plesk_remote_vulnerability_checker.php

"%plesk_dir%\additional\PleskPHP5\php.exe" -d safe_mode=0 plesk_remote_vulnerability_checker.php

The output of this script will be one of the following:

1. The patch has been successfully applied -- if recommended fixes have been installed.
2. The file <missed file name> has not been found. The patch is not applicable -- if the target files are missing on the server.
3. The patch has not been applied -- if recommended fixes haven't been installed.
4. The file <version file name> has not been found -- if Plesk version file has not been found.
5. Failed to get Plesk version from <version file name> -- if Plesk version file has been corrupted.
6. Plesk is up to date -- if you are using Plesk 10.4.x.

If the output reads "The patch has not been applied," please refer to this KB article: to learn how to apply the patch.


56797cefb1efc9130f7c48a7d1db0f0c aac4a8fcd879de03758354e15495d69a a914db3fdc7a53ddcfd1b2db8f5a1b9c 85a92ca67f2200d36506862eaa6ed6b8 c796c01d6951fa24ed54c7f1111667c6 c45acecf540ecd42a4bbfb242ce02b1d b8ef5052d936e902043e41759118114e 29d1e90fd304f01e6420fbe60f66f838 dd0611b6086474193d9bf78e2b293040 6ef0db7f1685482449634a455d77d3f4

Email subscription for changes to this article
Save as PDF