Article ID: 113452, created on Mar 13, 2012, last review on Apr 30, 2014

  • Applies to:
  • Virtuozzo containers for Linux 4.0

Release notes

--------------------------------------------------------------------------------
Synopsis:          New Parallels Virtuozzo Containers 4.0 kernel provides an
                   update with security and stability fixes.
Issue date:        02-12-2012

Product:           Parallels Virtuozzo Containers 4.0
Keywords:          "bugfixing" "stability" "security"

--------------------------------------------------------------------------------

This document provides information on the new Parallels Virtuozzo Containers 4.0
kernel, version 2.6.18-028stab099.3.

--------------------------------------------------------------------------------
TABLE OF CONTENTS

1. About this Release
2. Update Description
3. Obtaining New Kernel
4. Installing New Kernel
5. Required RPMs
6. References

--------------------------------------------------------------------------------

1. ABOUT THIS RELEASE

The current update for the Parallels Virtuozzo Containers 4.0 kernel provides a
new kernel based on the Red Hat 5.8 kernel (2.6.18-308.el5). The updated
kernel includes a number of security and stability fixes.

--------------------------------------------------------------------------------

2. UPDATES DESCRIPTION

This update contains fixes for the following issues:

- The "kernel.dmesg_restrict" sysctl configured on the Node should not restrict
  access to a Container's dmesg buffer from inside the Container.
  (OVZ bug# 2197)

- An online migration of a Container with bindmounted files inside could fail.
  In particular, bindmounted files are used by modern versions of the "named"
  service. (PCLIN-30785)

- An attempt to create a tun device in persistent mode inside a Container
  could make it impossible to perform any network-related management operations
  on the Node. (OVZ# 2207)

This update also contains a fix for the following security issue:

* A flaw was found in the way the Linux kernel's Event Poll (epoll)
  subsystem handled large, nested epoll structures. A local, unprivileged user
  could use this flaw to cause a denial of service. (CVE-2011-1083, Moderate)

--------------------------------------------------------------------------------

3. OBTAINING NEW KERNEL

You can download and install this kernel update using the vzup2date utility
included in the Parallels Virtuozzo Containers 4.0 distribution set.

--------------------------------------------------------------------------------

4. INSTALLING NEW KERNEL

To install the update, do the following:

I. Use the "rpm -ihv" command to install the new kernel and Virtuozzo modules.

# rpm -ivh vzkernel-2.6.18-028stab099.3.i686.rpm \
vzmodules-2.6.18-028stab099.3.i686.rpm
Preparing...                ################################# [100%]
    1:vzkernel               ################################# [50%]
    2:vzmodules              ################################# [100%]

    Please DO NOT USE the "rpm -Uhv" command to install the kernel. Otherwise,
    all the kernels previously installed on your system may be removed from
    the Hardware Node.

II. You can adjust your boot loader configuration file to have the new kernel
    loaded by default. If you use the LILO bootloader, please do not forget to
    execute the "lilo" command to write the changes to the boot sector:

     # lilo
     Added Virtuozzo2 *
     Added Virtuozzo1
     Added linux
     Added linux-up

III. Reboot your computer with the "shutdown -r now" command to boot the new
     kernel.

--------------------------------------------------------------------------------

5. REQUIRED RPMS

Depending on the processor installed on the Hardware Node, the following RPM
packages are included in the kernel update:

x86 kernels:

- SMP:
   vzkernel-2.6.18-028stab099.3.i686.rpm
   vzmodules-2.6.18-028stab099.3.i686.rpm

- Enterprise:
   vzkernel-ent-2.6.18-028stab099.3.i686.rpm
   vzmodules-ent-2.6.18-028stab099.3.i686.rpm

- Enterprise with the 4GB split feature disabled:
   vzkernel-PAE-2.6.18-028stab099.3.i686.rpm
   vzmodules-PAE-2.6.18-028stab099.3.i686.rpm


x86_64 kernels:

- SMP:
   vzkernel-2.6.18-028stab099.3.x86_64.rpm
   vzmodules-2.6.18-028stab099.3.x86_64.rpm

--------------------------------------------------------------------------------

6. REFERENCES

https://rhn.redhat.com/errata/RHSA-2012-0150.html
https://www.redhat.com/security/data/cve/CVE-2011-1083.html

--------------------------------------------------------------------------------
Copyright (c) 1999-2012 Parallels Holdings, Ltd. and its affiliates. All rights
reserved.

35c16f1fded8e42577cb3df16429c57a d02f9caf3e11b191a38179103495106f e8e50b42231236b82df27684e7ec0beb 2897d76d56d2010f4e3a28f864d69223

Email subscription for changes to this article
Save as PDF