Article ID: 113750, created on Apr 23, 2012, last review on Mar 7, 2016

  • Applies to:
  • Plesk Sitebuilder for Windows


I am getting the following error on step 4 of the Parallels Plesk Sitebuilder (PPSB) Wizard for all domains:
The page at http://<server_IP>:2006/Sites/<site_id> is unavailable. Please contact your Plesk Sitebuilder provider to resolve this problem.
In the PPSB log ( C:\Program Files (x86)\Sitebuilder\_logs\Application.log ) I see:
System.Net.WebException: The remote server returned an error: (503) Server Unavailable.
   at System.Net.HttpWebRequest.GetResponse()
   at SWsoft.SiteBuilder.Web.UI.WebControls.EditPageControl.OnLoad(EventArgs e)
2012-04-06 15:07:50,936 [9] FATAL SWsoft.SiteBuilder.Web.UI.WebControls.EditPageControl - Preview site by this url http://<site>:2006/Sites/<site_id>/ is unavailable.


Most probably the issue is with the application pool used by the ‘<site_id>'. It either uses an unsupported .NET Framework version (3.0/4.0) or it is stopped.
By design PPSB 4.5 for Windows supports only .Net Framework version 2.0 (it is mentioned in the system requirements).
To diagnose the issue check which application pool is used by the site and its version:
IIS -> Sites -> Sitebuilder Web Site -> Sites -> <site_id> -> *Manage Application -> Advanced Settings...*:
Application Pool: <APP_POOL_NAME>
.Net Framework Version: 4.0
After that go to
IIS -> Application Pools
And verify that the above application pool is started.


If the application pool is stopped, start it.
If the .NET Framework version is higher than 2.0, switch it to a lower value as described below:
1.       Verify that ASP.NET 2.0 works correctly:

Go to IIS Management console and find a domain which runs ASP.NET 2.0 (open its advanced settings as described above)

Then go to http://domain.tld/test/aspnet/test.aspx

Note: Replace domain.tld with the actual domain name.

Test if the page works correctly.

2.       Go to IIS Manager and change the version of .NET Framework used by the application pools of PPSB sites, for example:
IIS -> Application Pools -> <APP_POOL_NAME> -> .NET Framework v2.0.50727
This KB article may also be useful for you:
9518 Parallels Plesk Sitebuilder 4.5 is not available after fresh installation: Internal system error

fad6dc0c8e983c17ae70a51ac7952cd0 2a62cbceb986d1b8f45bcd3ff4cb29a5 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF