Article ID: 114499, created on Aug 2, 2012, last review on Aug 12, 2014

  • Applies to:
  • Plesk 11.x for Linux
  • Plesk 10.x for Linux
  • Plesk 9.x for Linux/Unix
  • Plesk 8.x for Linux/Unix


This article is intended to help you with upgrading a Parallels Plesk Panel (PP) for Linux installation.

Useful resources

The most useful resource related to PP upgrades is this guide:

Installation, Upgrade, Migration, and Transfer Guide for Parallels Plesk Panel 11.0

Here are some examples of the information it provides:

    Which Upgrade Method to Choose - In-place or By Transfer
    In-Place PP Upgrading - Tells you how to prepare and carry out all three types of in-place upgrade: Manual, automated, and upgrade in Parallels Virtuozzo Containers.

    Upgrading PO by Transfer - Covers the same points for upgrading by transfer, including upgrading through backup files.


Have a Linux administrator on hand
Each operating system environment is unique in terms of package states, and it is impossible to test all possible scenarios. Due to this fact, most upgrade failures happen due to package dependency errors. Therefore, we recommend that during the time of the upgrade, you have a system administrator available who is capable of resolving common package dependency issues.

Get rid of third-party packages (exception: Atomic packages)
Many kinds of issues may occur if 3rd-party PP software components are installed from 3rd-party repositories. The only exception is the Atomic repository, which is not packaged by Parallels, but is thoroughly tested on both sides of development. If you have 3rd-party packages from other repositories, and they are not essential, we suggest that you replace them with the ones from the Parallels repository before upgrading PP. Do not forget to clean the YUM repository list and cache beforehand.

Upgrading from PP 9 and Earlier Versions
Parallels Plesk Panel 10 and higher versions have a very different object model compared to previous versions. Practically, this means that many objects, e.g., clients, will change roles. At the end of the upgrade, you will need to decide how exactly you want such changes to occur. You may prepare for this decision before the upgrade using this part of the Installation Guide.

Run the Pre-Upgrade Checker
If your PP version is 10.3 or earlier, before you actually begin the upgrade, you may want to run the following tool:
Parallels Plesk Panel Pre-Upgrade Checker - A tool to identify business logic issues before an upgrade or migration.
As of version 10.4, this tool is automatically run at the beginning of the upgrade process.

Good luck!

dd0611b6086474193d9bf78e2b293040 56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 6ef0db7f1685482449634a455d77d3f4 b8ef5052d936e902043e41759118114e 0a53c5a9ca65a74d37ef5c5eaeb55d7f

Email subscription for changes to this article
Save as PDF