Article ID: 116246, created on Jun 10, 2013, last review on May 9, 2014

  • Applies to:
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux

Symptoms

1. Install and configure Plesk 11.0.9 using version free templates.

2. Update template URLs (switch repo to Plesk 11.5.24: emulation of change link Plesk from 11.0.9 to 11.5.24).

3. Upgrade with vzpkg update, for example:
# vzpkg update -r CONTAINER_ID

Result: The upgrade completes, but Plesk is not available. The install log contains a lot of errors. PSA service is stopped.

Resolution

Explicitly specify packages for vzpkg update:

1. Install and configure Plesk 11.0.9 using version free templates, for example:
# vzpkg install -r CONTAINER_ID pp pp-kav pp-webmail pp-mailman pp-tomcat postgresql pp-migration pp-postfix pp-antivirus pp-watchdog pp-spamassassin pp-cf-support pp-panel-addons

2. Update template URLs (switch repo on Plesk 11.5.24: emulation of change link Plesk from 11.0.9 to 11.5.24).

3. Upgrade with vzpkg, with packages specified:

# vzpkg update -r CONTAINER_ID pp pp-kav pp-webmail pp-mailman pp-tomcat postgresql pp-migration pp-postfix pp-antivirus pp-watchdog pp-spamassassin pp-cf-support pp-panel-addons

Origin: In the case of vzpkg update -r, all installed packages are updated, but the templates' pre/post-update scripts are not executed.

aea4cd7bfd353ad7a1341a257ad4724a 56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 0a53c5a9ca65a74d37ef5c5eaeb55d7f 01bc4c8cf5b7f01f815a7ada004154a2

Email subscription for changes to this article
Save as PDF