Article ID: 116560, created on Jul 26, 2013, last review on May 11, 2014

  • Applies to:
  • Virtuozzo containers for Linux


It is not possible to install package with apt-get command:

root@localhost:/# apt-get install mc
Reading package lists... Done
Building dependency tree... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-i386 but it is not installable
 mc : Depends: mc-data (= 3:4.8.3-10) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


Package ia32-libs-i386 is available only in i386 repository that is not presented by default.


You need to add i386 architecture:

root@localhost:/#dpkg --add-architecture i386
root@localhost:/# apt-get update

After that you will be able to install packages.

As another workaround you can use force option:

root@localhost:/# apt-get install -f <package>

d02f9caf3e11b191a38179103495106f 2897d76d56d2010f4e3a28f864d69223 e8e50b42231236b82df27684e7ec0beb

Email subscription for changes to this article
Save as PDF