Article ID: 117126, created on Sep 5, 2013, last review on May 9, 2014

  • Applies to:
  • Virtuozzo
  • Virtuozzo containers for Linux
  • Virtuozzo hypervisor

Symptoms

I cannot install a package into container due to dependency conflicts :

    ~# vzpkg install 101 -p yum
    ...
    Error: Missing Dependency: rpm-libs = 4.4.2.3-22.el5_7.2 is needed by package rpm-python
    Error: Missing Dependency: popt = 1.10.2.3-22.el5_7.2 is needed by package rpm-python
    Error: Missing Dependency: rpm = 4.4.2.3-22.el5_7.2 is needed by package rpm-python

Cause

Container has older versions of packages installed in it, which do not satisfy the dependencies.

Resolution

Update all packages inside the container and try the installation again :

    ~# vzpkg update CTID
    ~# vzpkg install -p CTID yum

Search Words

vzpkg install

Error: Missing Dependency:

vzpkg update

a26b38f94253cdfbf1028d72cf3a498b 2897d76d56d2010f4e3a28f864d69223 d02f9caf3e11b191a38179103495106f e8e50b42231236b82df27684e7ec0beb 0dd5b9380c7d4884d77587f3eb0fa8ef

Email subscription for changes to this article
Save as PDF