Article ID: 117950, created on Oct 14, 2013, last review on May 10, 2014

  • Applies to:
  • Virtuozzo
  • Virtuozzo containers for Linux
  • Virtuozzo hypervisor


Installation of application template fails with the following (or similar) error:

[root@vz x86_64]# vzpkg install 110 pp
Setting up Install Process
Package yum-3.2.29-40.el6.centos.noarch already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package SSHTerm.noarch 0:0.2.2-10.13012810 will be installed
--> Finished Dependency Resolution
Error: Package: perl-IO-Compress-2.052-1.el5.rfx.noarch (base6)
           Requires: perl(Compress::Raw::Zlib) = 2.052
           Available: perl-Compress-Raw-Zlib-2.003-1.el5.rf.x86_64 (base5)
               perl(Compress::Raw::Zlib) = 2.003
           Available: perl-Compress-Raw-Zlib-2.005-1.el5.rf.x86_64 (base5)
               perl(Compress::Raw::Zlib) = 2.005
           Available: perl-Compress-Raw-Zlib-2.006-1.el5.rf.x86_64 (ba
Error: Package: perl-DBD-MySQL-4.022-1.el5.rfx.x86_64 (base6)
Error: Package: perl-DBD-MySQL-4.022-1.el5.rfx.x86_64 (base6)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Error: /usr/share/vzyum/bin/yum failed, exitcode=1


Packages dependencies can not be resolved properly because of unsupported repository mirror(s) in the corresponding OS template.


Remove the custom repository mirror(s) from the corresponding OS template. Example:

[root@vz x86_64]# cat /vz/template/centos/6/x86_64/config/os/default/mirrorlist

Mirrors and are not supported and have to be excluded from the mirror list. Only official CentOS repositories are supported.

Search Words

application template

/usr/share/vzyum/bin/yum failed

vzpkg install

Dependency Resolution


d02f9caf3e11b191a38179103495106f 2897d76d56d2010f4e3a28f864d69223 a26b38f94253cdfbf1028d72cf3a498b e8e50b42231236b82df27684e7ec0beb 0dd5b9380c7d4884d77587f3eb0fa8ef

Email subscription for changes to this article
Save as PDF