Article ID: 117982, created on Oct 16, 2013, last review on May 11, 2014

  • Applies to:
  • Virtuozzo
  • Virtuozzo containers for Linux
  • Virtuozzo hypervisor

Symptoms

An attempt to install the most recent EZ OS templates fails with the following (or similar) errors:

Dependencies conflict. 
vzpkgenvdeb >= 4.6.0-20 is needed by   ubuntu-12.04-x86-ez-4.7.0-2.noarch                           
vzpkgenvdebx64 >= 4.6.0-20 is needed by  ubuntu-12.04-x86_64-ez-4.7.0-3.noarch                        
vzpkgenvdeb >= 4.6.0-20 is needed by  ubuntu-12.10-x86-ez-4.7.0-1.noarch                           
vzpkgenvdebx64 >= 4.6.0-20 is needed by  ubuntu-12.10-x86_64-ez-4.7.0-1.noarch
vzpkgenvdeb >= 4.6.0-20 is needed by  ubuntu-12.10-x86_64-ez-4.7.0-1.noarch

Cause

New templates require the latest vzpkg environmental packages.

Resolution

Install all pending tools updates:

# vzup2date -m batch install --tools --self-update

Afterwards it should be possible to install/update new EZ OS templates.

Search Words

vzup2date

vzpkgenvdebx64

OS template

vzup2date -z

install

vzpkgenvdeb

a26b38f94253cdfbf1028d72cf3a498b 2897d76d56d2010f4e3a28f864d69223 d02f9caf3e11b191a38179103495106f e8e50b42231236b82df27684e7ec0beb 0dd5b9380c7d4884d77587f3eb0fa8ef

Email subscription for changes to this article
Save as PDF