Article ID: 118064, created on Oct 20, 2013, last review on Nov 24, 2014

  • Applies to:
  • Virtuozzo

Symptoms

There is a high load on one of the Parallels Cloud Server (PCS) clustered nodes, containers are not starting properly on it.

Message area of pstorage -c CLUSTER_NAME top is full of the following messages:

22-05-13 09:45:27  MDS WRN File operation requested by the client at 10.0.2.11:49789 is failed due to licensed capacity limit [+238/60] 
22-05-13 09:45:28  MDS WRN File operation requested by the client at 10.0.2.11:49789 is failed due to licensed capacity limit [+...]    
22-05-13 09:46:28  MDS WRN File operation requested by the client at 10.0.2.11:49789 is failed due to licensed capacity limit [+238/60]

On any attempt to start a container, the following error appears:

Failed to mount image /vz/private/CTID/root.hdd: Error in do_lock (lock.c:133): The /pstorage/pcs-cluster/private/CTID/root.hdd/DiskDescriptor.xml.lck is locked: Resource temporarily unavailable [152]

Cause

Parallels Cloud Storage license is marked as "GRACED", as the result - all I/O activity is blocked for files located on a PCS cluster.

Use the following command to find out what your license status is:

~# pstorage -c CLUSTER_NAME view-license | grep -i status
        status="GRACED"

(Replace "CLUSTER_NAME" with the actual PCS storage cluster name.)

Resolution

Check the output of pstorage -c CLUSTER_NAME get-event to find the exact message when the license entered "GRACED" status:

~# pstorage -c CLUSTER_NAME get-event
........
    18-10-13 11:32:57.433 MDS WRN: Size of stored data exceeds licensed capacity limit.
    18-10-13 11:32:57.439 JRN INF:   gen.license_status=7U
    18-10-13 11:32:57.439 MDS WRN: License PCSS.01111111.0001 is GRACED 

The similar output indicates that you are hitting the license capacity limit of your PCS storage license (PCSS).

An example of a license that allows you to have 100 GB of storage space (100GB is minimal licensed PCS storage capacity):

 ~# pstorage -c CLUSTER_NAME view-license | grep capacity
        capacity=100

Verify your PCS cluster mount point:

~# mount | grep pstorage
pstorage://CLUSTER_NAME on /pstorage/CLUSTER_NAME type fuse.pstorage (rw)

And then see how many space is occupied:

~# du -sh /pstorage/CLUSTER_NAME
106G    /pstorage/CLUSTER_NAME

If your licensed limit is indeed exceeded, consider upgrading your current license to have sufficient storage capacity.

Search Words

pcss license

licensed capacity

Size of stored data exceeds licensed capacity limit

failed due to licensed capacity

graced

0dd5b9380c7d4884d77587f3eb0fa8ef 2897d76d56d2010f4e3a28f864d69223

Email subscription for changes to this article
Save as PDF