Article ID: 118841, created on Nov 24, 2013, last review on May 11, 2014

  • Applies to:
  • Plesk for Linux/Unix
  • Virtuozzo containers for Linux


A container that has postfix and sendmail packages installed simultaneously cannot be updated, the operation fails with the following errors:

[root@vz ~] vzpkg update $CTID
Error: plesk-mail-qc-driver conflicts with plesk-mail-pc-driver
Error: plesk-mail-pc-driver conflicts with plesk-mail-qc-driver
Error: plesk-mail-pc-driver conflicts with psa-qmail
Error: plesk-mail-pc-driver conflicts with psa-qmail-rblsmtpd
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
Error: /usr/share/vzyum/bin/yum failed, exitcode=1


The behavior is recognized as a product bug with internal ID PPPM-1081.

A Plesk installation is capable of keeping only one mail server installation, so it is not advised to install any other mail servers manually.


Remove sendmail packages:

# rpm -e sendmail-doc sendmail-cf sendmail --nodeps

After this, the update procedure should go smoothly.

Search Words

update virtuozzo

postfix install failure

a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c d02f9caf3e11b191a38179103495106f 2897d76d56d2010f4e3a28f864d69223 e8e50b42231236b82df27684e7ec0beb 29d1e90fd304f01e6420fbe60f66f838

Email subscription for changes to this article
Save as PDF