Article ID: 119349, created on Dec 27, 2013, last review on May 10, 2014

  • Applies to:
  • Web Presence Builder 11.5


When I publish a site to my cPanel server, it shows error without support PHP extension. What should I set on my remote cPanel server to let it work well?


The PHP extensions should be enabled in the domain where the site is hosted (published). According to Release Notes the following PHP extensions are required:

The cPanel & WHM plugin requires that the following components be installed on the server where sites will be hosted:

    cPanel & WHM 11.38.0 with the x3 theme. The plugin cannot work with themes other than x3.
    PHP 5.2.x or later.
    The cURL PHP extension.

Installation of the cPanel & WHM plugin requires superuser privileges.

Presence Builder Standalone requires that the following components be installed on the cPanel & WHM server:

    PHP 5.2.x or later.
    ionCube Loader 3.1.15 or later.
    PHP extensions: dom, mbstring, zlib, and gd.

Please contact cPanel support for assistance with enabling the PHP extensions on the domain.

For information about how to configure cPanel & WHM to meet these requirements, refer to the document Prerequisites and Requirements

Additional information

Integrating Presence Builder with cPanel & WHM.

Search Words

Sitebuilder and cPanel



PHP extensions


9305481d3bd31663b68451e3bfdec5a5 56797cefb1efc9130f7c48a7d1db0f0c 18f5eb2d7a7972323627b40f015d5a19

Email subscription for changes to this article
Save as PDF