Article ID: 119384, created on Dec 27, 2013, last review on May 11, 2014

  • Applies to:
  • Virtuozzo
  • Virtuozzo containers for Linux
  • Virtuozzo hypervisor


apt-get upgrade inside of container based on debian-7.0-x86_64 fails with following error output:

root@debian:~# apt-get upgrade -f
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of bind9:
bind9 depends on libbind9-80 (= 1:9.8.4.dfsg.P1-6+nmu2+deb7u1); however:
Package libbind9-80 is not configured yet.
bind9 depends on libdns88 (= 1:9.8.4.dfsg.P1-6+nmu2+deb7u1); however:
Package libdns88 is not configured yet.
dpkg: error processing bind9 (--configure):
dependency problems - leaving unconfigured`
dpkg: dependency problems prevent configuration of expat:
expat depends on libexpat1 (>= 2.0.1); however:
Package libexpat1:amd64 is not configured yet.

dpkg: error processing expat (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)


Container has multiarch packages installed, however dpkg is configured to maintain only amd64 packages:

root@debian:~# dpkg --print-architecture
root@debian:~# dpkg --print-foreign-architecture

As a result of such configuration, apt-get attempts to update only amd64 packages, ignoring installed i386 packages. It causes errors when apt-get tries to update multiarch packages — apt-get won't be able to update amd64 packages because they wont match i386 package's version (it is crucial for multiarch mechanism to have both amd64 and i386 packages' version in sync).


To be able to update multiarch packages you should enable i386 support in dpkg inside of container:

root@debian:~# dpkg --add-architecture i386

Once i386 support is enabled it is necessary to clean apt-get cache and download packages list anew:

root@debian:~# apt-get clean; apt-get update

As a result of previous apt-get upgrade attempt you still might have errors in dpkg (installed but not configured packages), these errors can be fixed using following command:

root@debian:~# apt-get install -f

Now you should be able to run upgrade:

root@debian:~# apt-get upgrade

Search Words

dependency problems prevent configuration of

apt-get upgrade

is not configured yet.

dependency problems - leaving unconfigured

apt-get update


apt-get -f install

apt-get install -f

Errors were encountered while processing

a26b38f94253cdfbf1028d72cf3a498b 2897d76d56d2010f4e3a28f864d69223 d02f9caf3e11b191a38179103495106f e8e50b42231236b82df27684e7ec0beb 0dd5b9380c7d4884d77587f3eb0fa8ef

Email subscription for changes to this article
Save as PDF