Article ID: 119463, created on Jan 2, 2014, last review on Aug 31, 2016

  • Applies to:
  • Plesk 11.0 for Linux


Plesk upgrade fails with error:

    ERROR 1290 (HY000) at line 1: The MySQL server is running with the --skip-grant-tables option so it cannot execute this statement 


Option skip-grant-tables is enabled in /etc/my.cnf.


  1. Disable option skip-grant-tables in /etc/my.cnf as below:

    for RedHat-based OS

    # vi /etc/my.cnf

    for Debian-based OS

    # vi /etc/mysql/my.cnf
  2. Restart MySQL server:

    for RedHat-based OS

    # /etc/init.d/mysqld restart

    for Debian-based OS

    # /etc/init.d/mysql restart
  3. Check MySQL server connectivity:

    MYSQL_PWD=`cat /etc/psa/.psa.shadow` mysql -u admin psa
  4. Start the upgrade again

Search Words

Information: The administrator's password cannot be sent by e-mail for security reasons. You can use the plesksrvclient.exe utility located in C:\Plesk\admin\bin to set up a new password.


a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c aea4cd7bfd353ad7a1341a257ad4724a 29d1e90fd304f01e6420fbe60f66f838 0a53c5a9ca65a74d37ef5c5eaeb55d7f

Email subscription for changes to this article
Save as PDF