Article ID: 119534, created on Jan 9, 2014, last review on Jan 9, 2014

  • Applies to:
  • Plesk 10.4 for Windows


Fastcgi PHP does not work on Windows 2003. When I try to open any PHP page, I got the following errora:

    Invalid data


    Page not found

If I switch PHP extension on domains to ISAPI, PHP works fine.


FastCGI installation is broken.


  1. Find fastcgi-i386.msi package. For Plesk 10.4 it is located here:

  2. Launch this package and reinstall it on the server. Please note this package is valid for Windows 2003 only.

Search Words

failed upgrade

ff5a00b8ead2e480367b019417a04207 56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 85a92ca67f2200d36506862eaa6ed6b8 c796c01d6951fa24ed54c7f1111667c6

Email subscription for changes to this article
Save as PDF