Article ID: 120087, created on Feb 12, 2014, last review on May 10, 2014

  • Applies to:
  • Panels
  • Virtuozzo 6.0
  • Virtuozzo containers for Linux

Symptoms

I want to upgrade Operating System (OS) in a container with PBA-S installed. The following error appears when I try to upgrade via PVA:

Error
Failed to get list of available updates.
Error:  Failed to retrieve a list of updates for the installed software. (Details)

Error Details
Can not update packages: ' vzpkg update -q -n -p 99' exec failed - Error: Missing Dependency: whois >= 4.6.26 is needed by package hspc-release-4.5-55.swsoft.i386 (installed)
Error: Missing Dependency: /usr/lib/perl5/site_perl/5.8.8/XML/SAX.pm is needed by package hspc-release-4.5-55.swsoft.i386 (installed)
Error: Missing Dependency: perl(IPC::ShareLite) is needed by package hspc-release-4.5-55.swsoft.i386 (installed)

Cause

The OS upgrade in PBA-S container is not performed the usual way.

Resolution

Use the instructions from these KB articles for upgrading OS in a container with PBA-S installed:

How to update OS (minor) of PBA-S server

How to upgrade OS (major) of PBA-S server or migrate PBA-S to new container

Search Words

Failed to retrieve a list of updates for the installed software

cannot upgrade OS of PBA-S

Failed to retrieve a list

upgrade

upgrade operating system

Missing Dependency

e8e50b42231236b82df27684e7ec0beb 2897d76d56d2010f4e3a28f864d69223 d02f9caf3e11b191a38179103495106f 400e18f6ede9f8be5575a475d2d6b0a6 caea8340e2d186a540518d08602aa065 c62e8726973f80975db0531f1ed5c6a2 0dd5b9380c7d4884d77587f3eb0fa8ef 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF