Article ID: 121094, created on Apr 15, 2014, last review on May 11, 2014

  • Applies to:
  • Plesk 11.5 for Linux


Plesk left navigation frame displays "bad gateway" error. '/var/log/sw-cp-server/error_log' contains the alike error messages:

2014/04/15 20:01:28 [error] 19509#0: *319 recv() failed (104: Connection reset by peer) while reading response header from upstream, client:, server: , request: "GET /left.php3 HTTP/1.1", upstream: "fastcgi://unix:/var/run/sw-engine.sock:", host: "", referrer: ""


MySQL packages were upgraded to version 5.6 from the third party repository during the updates installation.


  1. Check the client packages versions. The below example indicates the problem: packages are installed from 'Dotdeb' repo, which is wrong.

    dpkg -l|grep libmysqlclient
    ii  libmysqlclient18:amd64               5.6.17-1~dotdeb.1                   amd64
    ii  libmysqlclient-dev                   5.6.17-1~dotdeb.1                   amd64
  2. Remove the custom packages:

    dpkg -r --force-depends libmysqlclient18
    dpkg -r --force-depends libmysqlclient-dev
  3. Comment out the Dotdeb in '/etc/apt/sources.list' file.

  4. Install the default packages from official Debian repo:

     apt-get install libmysqlclient18 libmysqlclient-dev

a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c 01bc4c8cf5b7f01f815a7ada004154a2 29d1e90fd304f01e6420fbe60f66f838 0a53c5a9ca65a74d37ef5c5eaeb55d7f

Email subscription for changes to this article
Save as PDF