Article ID: 121511, created on May 9, 2014, last review on May 11, 2014

  • Applies to:
  • Plesk 11.5 for Linux


An attempt to update Wordpress produce permission error:

Can't create folders or files.


Wrong permissions on Worpress installation files.


By default the Wordpress APS application is installed with permissions 646 for files and 757 for folders. You can use the script which sets the permissions for Worpress installation to default:

#Path to Wordpress installation 
#Restore permissions to the default 
find $wp_path -type d -exec chmod 757 {} \; 
find $wp_path -type f -exec chmod 646 {} \;

Create the script on your server, add the executable permissions, and execute it giving the path to WP installation as a parameter:

vi fix_wordpress
chmod +x fix_wordpress
./fix_wordpress /var/www/vhosts/

More information regarding Wordpress permissions could be found in Wordpress Codex.

a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c 01bc4c8cf5b7f01f815a7ada004154a2 29d1e90fd304f01e6420fbe60f66f838 0a53c5a9ca65a74d37ef5c5eaeb55d7f

Email subscription for changes to this article
Save as PDF