Article ID: 122336, created on Jul 11, 2014, last review on Jul 11, 2014

  • Applies to:
  • Plesk 12.0 for Linux


Upgrade from Plesk 11.5 to 12 version fails with the following error:

YumRPMCheckError: [u'ERROR with rpm_check_debug vs depsolve:', 'psa-logrotate is needed by plesk-service-node-utilities-12.0.18-cos6.build1200140606.15.x86_64', u'Please report this error at']


The psa-logrotate package is not presented on the server.


  1. Verify that psa-logrotate is not installed:

    # rpm -qa | grep psa-logrotate
  2. Downloaded and installed that package manually from, please use corresponding OS version and architecture.

    Here is the example for CentOS 6 x86_64:

    # wget
    # rpm -i psa-logrotate-3.8.2-cos6.build115130211.11.x86_64.rpm
  3. Run Plesk upgrade:

    # /usr/local/psa/admin/sbin/autoinstaller

Search Words


psa-logrotate is needed by plesk-service-node-utilities

ERROR with rpm_check_debug vs depsolve

29d1e90fd304f01e6420fbe60f66f838 56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 2a5151f57629129e26ff206d171fbb5f e335d9adf7edffca6a8af8039031a4c7

Email subscription for changes to this article
Save as PDF