Article ID: 122999, created on Sep 24, 2014, last review on Jun 17, 2016

  • Applies to:
  • Virtuozzo containers for Linux 4.7


I'm trying to install CentOS 7 templates using the command vzup2date -z, and the installation fails with errors:

[RPM] Dependencies conflict. 
centos-7-x86_64-ez is needed by
centos-7-x86_64-ez is needed by 
centos-7-x86_64-ez is needed by


The CentOS 7 template is not supported in Virtuozzo Containers 4.7 yet, support for CentOS 7 template has been included in Virtuozzo only:

  • 122404 [Release notes] CentOS 7 EZ templates for Virtuozzo (formerly Parallels Cloud Server)

The reason why such templates are listed in output of vzup2date related to that fact that Plesk templates are shipped for Virtozzo Containers 4.7:

~# vzup2date -z -m batch list --all-app | grep -i centos-7 | head -n 5
For centos-7-x86_64-ez
  [pp-antivirus-centos-7-x86_64-ez/4.7.0-36.prl.334114] ... (  not installed  )
  [pp-bind-centos-7-x86_64-ez/4.7.0-36.prl.334114] Pp-bind  (  not installed  )
  [pp-centos-7-x86_64-ez/4.7.0-36.prl.334114] Pp            (  not installed  )
  [pp-cf-support-centos-7-x86_64-ez/4.7.0-36.prl.334114]... (  not installed  )

~# vzup2date -z -m batch list --all-os | grep -i centos-7


The situation has been reported to the developers, the internal request is PPPM-1927. The fix is planned to be included in one of the future updates.

Search Words

ez template

centos 7

CentOS 7

centos-7-x86_64-ez is needed by



e8e50b42231236b82df27684e7ec0beb 2897d76d56d2010f4e3a28f864d69223 d02f9caf3e11b191a38179103495106f 0c05f0c76fec3dd785e9feafce1099a9

Email subscription for changes to this article
Save as PDF