Article ID: 123697, created on Nov 27, 2014, last review on Jan 19, 2015

  • Applies to:
  • Plesk 12.0 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 10.4 for Linux/Unix


I cannot upgrade/update Plesk with error:

    Error message or request description : Error: Unable to start Parallels Products Installer. The following error has occurred: Execution failed. Command: autoinstaller Arguments: Array ( [0] => --service-mode [1] => --enable-xml-output [2] => --ssl-cert [3] => /usr/local/psa/admin/conf/httpsd.pem [4] => --branch [5] => current,release,stable ) Details: file does not exist or is not executable: /usr/local/psa/admin/bin/autoinstaller


Plesk autoinstaller is corrupted due to previous failed upgrade attempts.


  1. Go to in web browser and navigate down the directory structure according to your Plesk version and your operating system version.

  2. In opt/updater subdirectory find psa-autoinstaller package and copy its URI

  3. Download the psa-autoinstaller package from Plesk repository using the URI:

  4. Install the downloaded package:

    rpm -Uvh psa-autoinstaller-<version>.rpm
  5. Re-run Plesk update

Search Words

file does not exist or is not executable: /usr/local/psa/admin/bin/autoinstaller

Execution failed

Error: Unable to start Parallels Products Installer

file does not exist or is not executable

56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c aea4cd7bfd353ad7a1341a257ad4724a 29d1e90fd304f01e6420fbe60f66f838 0a53c5a9ca65a74d37ef5c5eaeb55d7f 01bc4c8cf5b7f01f815a7ada004154a2 2a5151f57629129e26ff206d171fbb5f e335d9adf7edffca6a8af8039031a4c7 e8756e9388aeca36710ac39e739b2b37 dd0611b6086474193d9bf78e2b293040

Email subscription for changes to this article
Save as PDF